Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 diving in the waterfall

Discussion in 'Phantom 2 Help' started by felipedrone, Jan 18, 2016.

  1. felipedrone

    Joined:
    Nov 24, 2014
    Messages:
    13
    Likes Received:
    0
    Hey guys,
    I have a phantom 2 with a chinese gimbal attached, plus a gopro 3+.

    Since the first time i flew it I experienced problems. At the first test it lost contact with the remote just a few meters away and it came back home, crashing on a tree but not breaking anything...
    Every time I fly something goes wrong. It tries coming back home (the taking off point), it goes down by itself at a high speed... Last week I was flying near a waterfall and it had half battery (2 green lines) and I was flying for 5 minutes with no problems. It suddenly went to the opposite side of home and then flew down so fast that I couldn't even try gaining back control. It fell hardly at the rocks. I've searched videos around the Internet and every video I see, people don't usually have problems like that! The remote controls batteries are good, the drone batt was half full, everything was apparently working fine, the attached GoPro's wifi was off...the drone's settings at factory settings. The rc switches were at the right positions also. It got wet after being underwater for 3 minutes. I left it for 2 weeks in a big rice bag to help it getting dry. One of my questions is if this is normal...it's unbelievable that every time something goes wrong and the phantom acts on its own!

    The other question:
    I reassembled it and turned it on. Normal powering sound. Yellow lights blinking...but when I turn on the RC the drone red lights start blinking fast and I'm not able to control anything with the RC. If I switch the right switch to the most down position (ATTI), the yellow lights go blinking again, but still no controlling is possible.

    That's it! Hope someone can help me.

    PS: The gopro is 100% working even after 3 minutes underwater without the case =)

    Thanks,
    Felipe
     
  2. felipedrone

    Joined:
    Nov 24, 2014
    Messages:
    13
    Likes Received:
    0
    Now I calibrated the compass and the red light keeps on, no blinking anymore...

    Anyone?

    Thank you guys
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Have you plugged it into the PC/Mac and run the Phantom Assist to assess the errors??
    It may just need an Adv IMU calibration.
     
    felipedrone likes this.
  4. felipedrone

    Joined:
    Nov 24, 2014
    Messages:
    13
    Likes Received:
    0
    Hey Mako I did the IMU calibration and the assistant shows "Error[33]" Description: "None". The red light still blinks (it just not blink when the RC is set to Failsafe mode. In that case it blinks yellow)

    I contacted dji already, but any help here would be awesome!

    Thanks