Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 1/FC40 with gimbal

Discussion in 'Phantom 1 Help' started by Freddy Birch, Mar 27, 2016.

  1. Freddy Birch

    Joined:
    Jan 30, 2016
    Messages:
    4
    Likes Received:
    0
    Hello! I have recently bought a gimbal for my Phantom 1 (FC40 without camera). The gimbal works fine after connecting to power, but i can't manage to find out how to make the controller tilt the camera.

    The controller works fine, both the sliders and the wheel to tilt the camera are moving. Also after calibration in Nazam. I also have tested the F1 and F2 ports, which have a small current who increase/decrease when i turn the wheel.. But still, no movement on the gimbal..

    The manual was a A4-page in chinese, so not much help there either. It says Arris on the gimbal, but have not found anything useful on the web for this..
     
  2. gianni_BT

    Joined:
    Jun 24, 2015
    Messages:
    128
    Likes Received:
    14
    Location:
    Tradate(VA).Italy
    The gimbal controller seems to be a SimpleBGC 8 bit.
    One of the possibilities that can explain why the pitch of your gimbal cannot be driven by the Naza F2 port is that the pitch input is not programmed to accept PWM signal, that is the standard the Naza is working with.
    You can discover this only by connecting to the USB port that is visible on one of the gimbal pictures.
    If you do not know what software your gimbal uses, try with the CP210xVCP driver and the SimpleBGC2_2b graphic interface. In the SimpleBGC internet site you can find different releases, but the 2_2B is the most common for these types of low cost gimbal.
    Do not forget to power the gimbal BEFORE you connect the USB port and remove the USB port BEFORE removing the power.
    Before doing anything, simply be sure that the gimbal option in your NAZA is switched ON.
     
  3. Freddy Birch

    Joined:
    Jan 30, 2016
    Messages:
    4
    Likes Received:
    0
    Thanx so much for your answer! I have also switched the gimbal option to ON before i tested, but still nothing happens.
    Have looked around on the SimpleBGC, but i'm not more wiser.. Waiting for feedback from the producer of the gimbal.
     
  4. gianni_BT

    Joined:
    Jun 24, 2015
    Messages:
    128
    Likes Received:
    14
    Location:
    Tradate(VA).Italy
    Another common issue is to reverse the signal and ground from Naza. The signal on the Naza F2 port is the pin at the bottom, while the ground is the pin at the top. The ground is mandatory if you power your gimbal with a separate source from the Fhantom battery. If you power the gimbal with the Phantom battery, you can connect ONLY the signal wire. Be sure you have connected the bottom pin of your Naza F2 port with the right signal pin of your gimbal.In the pictures of your gimbal, it looks there is a built-in cable for pitch control that uses 2 wires: be carefull that the yellow wire is connected to the bottom pin of the Naza and to the signal pin(not GND) of the gimbal.
     
    #4 gianni_BT, Mar 29, 2016
    Last edited: Mar 29, 2016
  5. Scottwillo

    Joined:
    Mar 13, 2016
    Messages:
    115
    Likes Received:
    12
    Can this also cause the pitch lever not to work at all???


    Sent from my iPad using PhantomPilots mobile app
     
  6. gianni_BT

    Joined:
    Jun 24, 2015
    Messages:
    128
    Likes Received:
    14
    Location:
    Tradate(VA).Italy
    If the electrical connection is wrong, the answer is "yes".
    If the electrical connection is OK, so there can be other reasons(PWM or other signal standard set-up, gimbal management not enabled in Naza etc.), but the electrical connection is the first item to be absolutely sure about.