Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 1.1.1 flashing yellow rapidly

Discussion in 'Phantom 1 Help' started by Marshal, Dec 25, 2015.

  1. Marshal

    Joined:
    Dec 25, 2015
    Messages:
    3
    Likes Received:
    0
    Hey there, newbie here. Hoping to get help from you pros. I'm very new at this.
    About 6 months ago My phantom 1.1.1 had unexpected fall into the pool. I disconnected the battery and took the top shell off and blew it with my air compressor. Let it sit out in the sun for 2 days. I travel a lot for work and now trying to see if I can get this thing back in the air.
    So far I've only 3 motors working. So I'll need to replace one.
    I'm also having an issue with the yellow light flashing rapidly. I've researched all day online and still can't figure it out. So now I'm here.
    I've calibrated the remote. The led light in the battery compartment is solid green as well as the light on the remote. It does have the latest update that I did about a week ago.
    When I connect to the my laptop with the naza-m v2 software I get no response when I'm trying to calibrate the RC. What's funny is I do get a response when I'm on RC System Assistant 1.2 software version but not on the Naza.
    Totally lost and have no idea what to try next. That's if there is anything. I'd greatly appreciate any help or advice.
     
  2. syotr

    Joined:
    Jul 30, 2013
    Messages:
    898
    Likes Received:
    136
    Sounds like your transmitter is not bound to the receiver or perhaps the receiver is bad. Make sure you have the receiver wires plugged into the correct ports on the NAZA.
     
  3. Marshal

    Joined:
    Dec 25, 2015
    Messages:
    3
    Likes Received:
    0
    Yes I must have. Just found a pic on here showing the correct ports. Powered up the phantom and went through normal flashing but now it's flashing red 3x or so with a break In between each set of red flashes. Getting somewhere I guess.
     
  4. Daverock

    Joined:
    Jan 7, 2016
    Messages:
    38
    Likes Received:
    1
    Does anyone have detailed pic of reciver wiring ports?
     
  5. Daverock

    Joined:
    Jan 7, 2016
    Messages:
    38
    Likes Received:
    1
    I did the same thing Marshal crashed into salt water bay, have some awesome footage of it just sickening... But yeah fried two ESC's.. Powers up flashing yellow no connection with transmitter.. Tried rebind no luck?
     
  6. Daverock

    Joined:
    Jan 7, 2016
    Messages:
    38
    Likes Received:
    1
    Gonna try new receiver..but that's just the start don't know what else is damaged..