Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

PFM (pure f'n magic)

Discussion in 'Phantom 1 Help' started by Wads, Sep 15, 2013.

  1. Wads

    Sep 15, 2013
    Likes Received:
    Good afternoon all, (well, California)

    So pre modification phantom= Awesome. Post modified phantom= :x So I upgraded radio to Dx8 and AR800 receiver w/sat. I've not had one malfunction w/stock phantom so one would think its something in my radio, receiver, or connection. I've made numerous flights ( preflight and range checks are good) and only one of 6 w/new setup went ok. First few my bust with incorrect fail safe set- that problem solved. Last few flights she went to fail safe and returned home. I jut don't know why. Receivers are mounted perpendicular greater than 2" apart as direct, batteries are good, nothing blocking line if site, range less than or equal to 400 ft. Last night while hovering about 4min into flight red led lights shut off (as well as the motors) the red remained on but reduced throttle to idle on its own and dropped like a rock from approx 300 ft. Absolutely nothing broke although I have yet to remove shell and inspect). Only doubts I have in my set up are my servo extensions. I had to put female ends on without the "tool" and I performed continuity checks on each one but that would be all I doubt. The other day I was flying- everything was fine and dandy about 2 min into flight and I had her at about 2 ft, she throttled straight up into a tree fell to the deck went full throttle after bouncing up into the sky probably about 200-300 ft hovered for 5 minutes, all motors cut off (I put radio down as I had no control and commenced with warning bystanders) and dropped like a rock and then at about 60 ft all motors started back up and recovered at about 20 ft than climbed to 60 ft (fail safe) and landed just fine. Gopro was on a caught it. Soooooo anyone experience similar? It is something new every time which would lead one to think electrical. If no one has any input I figure ill wait until my local store gets some extensions in and I'll just replace them. I've verified everything in naza assistant and it always looks great. Any info would be appreciated. I also emailed Spektrum- no reply.
  2. Audaciter

    Mar 18, 2013
    Likes Received:
    Sunnyvale, California, USA
    Wow, that must not be a good feeling to have, when the Phantom decides to have a mind of it's own.

    I don't know anything about the DX-8 radio and receiver you have, except they are known for their quality.

    My Futaba uses S-bus, so there is only 1 short wire going from the receiver to the Naza. Is your receiver capable of this
    as well ?

    Additionally, I know it is very important to keep your wires as short as possible, but without binding, to avoid interference.

    I would make custom length cables, over using extentions

    Also make sure your receiver isn't mounted directly on power systems on the main board, or other source of interference.

    Also the receiver antenna wires are delicate, and a crimp, or other form of damage would require replacing the antenna.
    If your receiver has 2 antenna's , they should be run as close to 90 deg. apart as much as possible.

    Good Luck.