Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Pahntom 2 with zenmuse h3-3d ... Doesn't face front

Discussion in 'Phantom 2 Discussion' started by hellhole, Jan 9, 2015.

  1. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Hey...
    I just got a set up of phantom 2 non vision and a zenmuse h3-3d ... It comes with the new transmitter ... With the gimbal control on the top left knob.

    After installing the gimbal... And power on. The gimbal did it's little dance and then face front but face 20-30 degree down. It works and balanced. But it just face 20-30 degree down...
    I have not used the transmitter... I can control the gimbal ... But can't go full face down.. And I have to keep holding on the knob for the gimbal to keep in place...

    Is there a need to update the gimbal? Transmitter ? Phantom?!
     

    Attached Files:

  2. capodrone81

    Joined:
    Nov 22, 2014
    Messages:
    362
    Likes Received:
    14
    Location:
    860

    yes connect and update! :mrgreen:
     
  3. alanw2005

    Joined:
    Jan 9, 2015
    Messages:
    38
    Likes Received:
    1
    You need to connect to the assistant software and then tell the software you are using the new transmitter. There is a transmitter menu. You have basic selected.
     
  4. Reoscorpio

    Joined:
    Nov 30, 2014
    Messages:
    242
    Likes Received:
    8
    Location:
    Lisle, IL
    I was told by y dealer that they all initialize and end up pointing down with the new firmware. As long as you have full control, you're fine.
     
  5. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    well.. I need to hold on to the knob for it to keep at a position. but its very limited movement. almost like 10degree from it backing down

    that is bad...
     
  6. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Let's start with a fresh slate.

    Uninstall the rc assist.
    Uninstall the phantom assist.

    Install the RC assist 1.2.
    Update the transmitter firmware.
    Calibrate all the sticks and move the tilt dial up and down. Then finalise. Close the rc assist.

    Download the phantom assist 3.6.
    Upgrade the zenmuse to latest firmware .10.
    Restart phantom.
    Goto Rc tab and select "upgrade mode".
    Calibrate all sticks and tilt dial. Finalise.
    Check your gimbal gains and horizontal and vertical.

    Let us know..
     
  7. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Okay. Updated everything ...



    Now the gimbal still face slightly down... As previous mention.

    Now I can use the rc to move the pitch and not need to hold on to it to hold the position.

    However... I can't get it to face fully front.

    Is this normal?
     

    Attached Files:

  8. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Start phantom assist 3.6.
    Look for the RC tab. Select upgrade mode and recalibrate all sticks including the tilt dial.
    Then goto the gimbal find the horizontal and vertical adjustments.
     
  9. mendezl

    Joined:
    Dec 14, 2014
    Messages:
    326
    Likes Received:
    10
    Location:
    Mandeville (New Orleans) Louisiana, USA
    you also need to select "new controller" not basic controller or something like that so that the software knows that you have the controller with the scroll wheel.
     
  10. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    If I am not wrong... I have to go to the 'gain' menu... Then adjust the pitch till I have it facing front?
     

    Attached Files:

  11. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Hi

    Here is the setting for the gain. I guess that is what I am looking for the gimbal ... I try to adjust the pitch to maximum (500)... But no change on the gimbal...



    Is the gimbal switch suppose to be ON?? I guess it should...



    I still can't get it to face totally front.

    Help! :)
     

    Attached Files:

  12. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Click Basic > RC > Calibrate all sticks and X1. Make sure you apply the setting.
    Then Click Advanced > Gimbal > nominate a gain, nominate horizontal and and vertical
     
  13. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Okay. Here is what I see at gimbal


    Adjusting it... To max on all option
    100 tilt control gain ( from about 40)
    30 horizontal limit (from -30)
    30 vertical limit ( from -30)

    A twig of the knob... Yes!!! It's about to move freely from really high to all the way


    Woohoo!!

    I end up putting the following
    Tilt control gain 50
    Horizontal limit 0
    Vertical limit 0

    the tilt control gain is...for the left right action of the gimbal?? I set it to 50 for now

    Thanks guys!!!
     

    Attached Files:

  14. csfanos

    Joined:
    Jan 11, 2015
    Messages:
    8
    Likes Received:
    0
    Thanks @Mako79 - that fixed it!

    @hellhole: the setting you need to change is Advanced -> Gimbal tab. My vertical limit was set far to the left at -30. I moved it over to +15 and now the camera will point straight ahead. Hope that works for you
     
  15. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Congrats guys. I'm glad you read my post.

    The tilt gain is for the speed of the tilt movement. The higher the more sensitive.

    When looking fwd, don't set to 0 as you will see the props when you are shooting wide angle on the Gopro.
     
  16. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Yes. I set to 0 for now. I will change it when I get the phantom flying. Next up is fpv
     
  17. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Yes. I set to 0 for now. I will change it when I get the phantom flying. Next up is fpv
     
  18. Mrsweep

    Joined:
    Sep 20, 2014
    Messages:
    59
    Likes Received:
    2
    Location:
    Coventry - UK
    ive got the same with mine and its driving me barmy !! will try all the things you have but im sure Ive tried everything. Did you twist the silver knob on the left then?
     
  19. Mrsweep

    Joined:
    Sep 20, 2014
    Messages:
    59
    Likes Received:
    2
    Location:
    Coventry - UK
    :D :D :D praise the lord .. It only worked !! Thanks guys
     
  20. hellhole

    Joined:
    Jan 4, 2014
    Messages:
    82
    Likes Received:
    0
    Glad that it did!!

    I leant a bit too from this...!!!