Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. driehl

    Joined:
    Jan 3, 2016
    Messages:
    117
    Likes Received:
    23
    In my go app my rc firmware says n/a ? I have feed and full control.. anyone know why this is not showing a version?

    Sent from my SM-N920C using PhantomPilots mobile app
     
  2. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,152
    Likes Received:
    1,664
    Location:
    San Francisco, CA
    You should see RC version when RC and P4 are also connected


    Sent from my iPhone using PhantomPilots
     
  3. driehl

    Joined:
    Jan 3, 2016
    Messages:
    117
    Likes Received:
    23
  4. Dacon Productions

    Joined:
    Jan 5, 2016
    Messages:
    592
    Likes Received:
    268
    Location:
    Gilbert, Arizona
    Power cycle all, had the same problem at first after GO app 3.0 update. This update is CRAP!. All the eggs in one basket for everything DJI came out with. Should be separate GO apps for different applications.
     
  5. Markus67

    Joined:
    Nov 24, 2016
    Messages:
    2
    Likes Received:
    0
    As I'm facing same issue as driehl, RC version N/A since last update (1.8?) and Video dropouts during flight, I was in contact with "DJI chat" and they couldn't help me.
    I tried to update/downgrade my RC using a USB-Stick but this seams not possible for P4 RC (only P3 RC can be updated via USB Stick?). Does someone knows where to download the right *.bin files for a P4 RC and knows how to apply them to the RC?
    I'm using app 3.1.0 (tested also 2.* versions but same issue) and latest FW on the Copter.
     
  6. driehl

    Joined:
    Jan 3, 2016
    Messages:
    117
    Likes Received:
    23
    Not sure what I did ..but I ended up powering up as usual...then shut off the p4 leaving the app and the rc on. Then it allowed me to downgrade rc via go app to 1.60.. All is good now. 3 miles easy no dropouts .

    Sent from my SM-N900W8 using PhantomPilots mobile app
     
    Turbomania likes this.
  7. Markus67

    Joined:
    Nov 24, 2016
    Messages:
    2
    Likes Received:
    0
    Success! Possibly this might help others having the weak Video signal issue due to RC FW Version > 1.6.0 and the RC FW Version not downgradable via the app as it is displayed as N/A.
    I'll post a few different things I've done and not all might be needed but at least it worked for me:
    1) Via USB connect P4 to PC and use DJI Assistant 2,
    1a. Restore Factory Defaults
    1b. update P4 to latest FW 1.2.602
    disconnect P4 from PC
    2) insert a fresh SD-Card in P4 and format it via the DJI Go app (as I found a logfile on my old Card saying something about version 1.8.* installed)
    3) performed a IMU calibration
    4) Today My Samsung TabS asked to update to Android 6.0.1 and after that also the DJI GO app asked to update the 3.1.0 Version (yes there is a updated Version dated 25.11.2016).

    It works again. The app Displays correctly the RC FW Version and lets me downgrade to 1.6.0 (even would be 1.5.8 available)

    Testflight and nearly no Video issues anymore!!!
    Looks like the RC Version 1.6.0 is key for stable Video.
    (Think, my Chat with DJI Support ended with "you will have to return it to the factory! I'm sorry I couldn't help you")