Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3S Limp camera and firmware

Discussion in 'Standard/4k Discussion' started by Willy720, Sep 6, 2016.

  1. Willy720

    Joined:
    Aug 10, 2016
    Messages:
    22
    Likes Received:
    2
    Location:
    Ct
    Hi All you great pilots!
    Can someone tell me why my camera goes limp after a few seconds after starting it up? The camera does right it self at first and I feel tension on it at first then it drops.

    Also I see a firmware updated needed but I get a message no SD card. I think it is because of the camera dropping out. Any help out there thanks alot!!!
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,782
    Likes Received:
    5,528
    Location:
    US
    I have a few questions for you:

    1) What changed between the time your Phantom last worked and this problem started occurring (did you crash, attempt to install new firmware, etc.)?

    2) Does that still occur if you remove the memory card before starting up your Phantom?
     
  3. Willy720

    Joined:
    Aug 10, 2016
    Messages:
    22
    Likes Received:
    2
    Location:
    Ct
    I did replace ribbon cable and took it back apart to go around the camera twice the right way. It seemed to be working with a camera picture last night for a hour then went out. It was after a crash. The firmware was after it was working last night but when trying to update all problems started. Thanks!!.
     
  4. Lukas Bergliden

    Joined:
    Aug 29, 2016
    Messages:
    10
    Likes Received:
    0