Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3S Gimbal not moving

Discussion in 'Standard/4k Discussion' started by ih8ra1n, Jun 17, 2016.

  1. ih8ra1n

    Joined:
    Jun 17, 2016
    Messages:
    5
    Likes Received:
    0
    Hey everybody!

    I've bought a P3S recently, started flying and in a couple of weeks faced some strange issue. My gimbal is not moving now.
    This is the full history. I've been flying, everything seemed to be ok, but suddenly my camera began shaking. I've landed my phantom, turned it off, turned on again, the camera has been still shaking. I've turned it off and on again and got no image transmission. And again. Than, I turn it off and on again, my camera faces down and not moving since then.

    I got the video, but no movements. I may move it with my hands but it passively gets back to facing straight down. What is the problem, what could cause it and what may i do? Any suggestions are appreciated.
    Thanks in advance.


    Sent from my iPhone using PhantomPilots mobile app
     
  2. HIGHFLIER

    Joined:
    Apr 20, 2016
    Messages:
    95
    Likes Received:
    32
    Can you post a video of it?
     
  3. ih8ra1n

    Joined:
    Jun 17, 2016
    Messages:
    5
    Likes Received:
    0
    Thanks for your answer. Unfortunately, no, I've already taken it to the service center to diagnose the problem. Just imagine, that it stays like it is turned off. The camera behaves as if it was not powered, though it has video.


    Sent from my iPhone using PhantomPilots mobile app
     
  4. Bob Thacker

    Joined:
    Mar 26, 2016
    Messages:
    25
    Likes Received:
    3
    Location:
    Minnesota
    Is there any chance it has water damage? About a week ago I got too low on a lake and soaked my camera but the rest of the drone stayed dry. The way you described yours was the exact way mine was acting before I dried the camera out in rice for a few days.
     
  5. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    gimbal cable is not "registering" due to a damage in the cable or your main board has an issue.
    just had that same issue on a bird last night and it ended up being the board.
     
  6. ih8ra1n

    Joined:
    Jun 17, 2016
    Messages:
    5
    Likes Received:
    0
    I suppose it could be related to water somehow, I've been flying right after the rain. Like it stopped raining just a couple of minutes before my flight, probably the air was still way too humid. That's great, that your bird has survived :)
     
  7. ih8ra1n

    Joined:
    Jun 17, 2016
    Messages:
    5
    Likes Received:
    0
    You mean the board of the gimbal or the one of the phantom itself? Sorry for your bird, Oh, I hope it's not tue board so much. The price for the repair in that case is nearly the full price of a new P3S. That's probably the worst case, that can ever happen to the phantom.
     
  8. ih8ra1n

    Joined:
    Jun 17, 2016
    Messages:
    5
    Likes Received:
    0
    Oh, btw, I forgot to mention one more thing. The camera has been shaking 2 times before it. The reboot seemed to fix the problem then.

    Thank you all for the answers, guys.
     
  9. alienmaster

    Joined:
    Jun 19, 2016
    Messages:
    7
    Likes Received:
    0
    That happened to mine after the firmware upgrade, help desk said to reset the camera. Small button on the side of the bird reset cured problems. Call help desk for instructions.