Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P w/ Fatshark Dominator V3's - No Signal

Discussion in 'Pro/Adv Discussion' started by Rrotz, Nov 4, 2015.

  1. Rrotz

    Joined:
    Oct 4, 2015
    Messages:
    62
    Likes Received:
    7
    Hey Everyone,

    I got a set of Fatshark Dominator V3's and I'm pairing them up with the P3P. I'm able to get an image thru the camera when I connect the HDMI cables to the HDMI output module on the Phantom 3, when I turn RX on...I get the OSD view in the goggles but No Signal on the app then vice versa and I'm not able to take off. Anyone know if I have something set up wrong or if this is a known issue?

    Thanks!
     
  2. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    867
    Location:
    San Antonio, TX
    go to the frequency screen and set the sliders--
     
  3. Rrotz

    Joined:
    Oct 4, 2015
    Messages:
    62
    Likes Received:
    7
    Exact setting is under Image Transmission Settings and Simultaneous image output to app and HDMI. I set that before but it resets each session I guess. Thanks Bob!
     
Loading...
Similar Threads - P3P Fatshark Dominator Forum Date
Fatshark module for P3P FPV (First Person View) Dec 16, 2016
P3P Original remote antennas Classifieds Today at 1:38 PM
DJI Goggles or Yuneec Skyview for P3P? Pro/Adv Discussion Tuesday at 5:19 PM
P3P loses video feed. Not signal related. Pro/Adv Discussion Monday at 6:49 PM
P3P ESC Status Error - Steps Taken So Far. Pro/Adv Discussion Monday at 6:43 PM