Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional P3P R/C firmware upgrade stuck at 45%

Discussion in 'Phantom 3 Help' started by Bad Company, Apr 9, 2016.

Tags:
  1. Bad Company

    Joined:
    Apr 1, 2016
    Messages:
    3
    Likes Received:
    0
    Location:
    Athens
    I got my brand new P3P yesterday, downloaded the GoApp (2.7.2) to my Samsung tablet, upgraded aircarft to 1.8.80 and the GoApp popped up a message to upgrade the RC. So I downloaded and started to upgrade the RC via the GoApp with f/w v. 1.6. The upgrade ended succesfully and the left led turned solid green.
    A couple of hours later I prepared for the first flight and I turned on the RC and the aircarft. The link was succesful, but I was surprised to see again a pop-up message in the GoApp to upgrade (again!) the RC... The message indicated that the f/w was downloaded and the upgrade was ready to start. So I hit start...

    Another suprise hit me as the new upgrade was for the same version that I already succesfully installed a few hours earlier: 1.6 !!! So I got a magical GoApp screen telling me that the RC was upgrading from v. 1.6 to v. 1.6 !!! The worst was yet to come, as the upgrade got stuck at 45% ... Almost half an hour later a decided to (abruptly) turn off the RC, as there was no progress and the buzzer started to sound strange.

    When I turned on again the RC, it connected to the GoApp, but a few seconds later the red led started to blink fast and the buzzer was signaling an error. The app displays connection error. I tried to perform f/w upgrade with all 3 alternative methods, but all failed.... I tried to downgrade the RC f/w but there is no f/w available in the downgrade list. I re-installed the GoApp but there is no message to upgrade the RC any longer.

    Did anybody have a similar experience? Any ideas?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,870
    Likes Received:
    5,558
    Location:
    US
    Is the DJI GO app showing "connection error" or "no signal"? Which versions are currently displayed in the "General Settings" --> "About" section of DJI GO?
     
  3. Bad Company

    Joined:
    Apr 1, 2016
    Messages:
    3
    Likes Received:
    0
    Location:
    Athens
    The error message in the app is "No signal"

    I can calibrate the R/C, but there is a message at the bottom "Linking RC"

    There is no f/w data on the gen settings-about section.

    There is available f/w to downgrade.


    No avail f-m.png



    Linking RC.png No signal.png No s-n.png
     
  4. SouthernPhantom

    Joined:
    Jun 10, 2015
    Messages:
    315
    Likes Received:
    122
    There are a number of things going on with the latest P3P release. The Go app was updated recently. Worst case, you should be able to delete and from your phone/tablet and reinstall it from the app store. Then, the RC and Phantom have new releases, also. This new firmware update requires that both the RC and the Phantom be updated concurently. They are updated in two separate operations. The RC is updated from the GO app. But the Phantom is still updated from the .bin file obtained from dji.com and then placed in the root directory of your SD card. If you update the RC first, it will show "connection lost" until the Phantom's firmware is updated, which is OK. If you haven't updated the firmware before, read the instructions carefully. On the P3P, it's not done until the little light on the front of the camera is solid green, no matter what the other lights are doing. The beeping sound can be confusing, too.