Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P - Loose or missing propeller / Motor obstructed

Discussion in 'Pro/Adv Discussion' started by TriadAerial, Aug 7, 2016.

  1. TriadAerial

    TriadAerial Guest

    I was flying today and suddenly I lost my video on my iPad and it went back to the main DJI Go App screen where you have to tap the large button that says Camera to see your view. When this happened I was about 200'-300' feet up and probably no more than 50' out so range was not an issue at all. Luckily my video feed came right back after tapping Camera on the screen. Keep in mind I didn't lose my signal or get any weak transmission error. Instead the entire screen in the DJI app just reverted back to the main page when you first open the app. So I got my video back and then 2 errors appeared in the top left corner.

    Missing or loose propeller.
    Motor obstructed.

    Scary messages for sure but I'm still up and flying with no issues. To be safe I brought her down and landed with zero issue. Turned off the bird and changed battery and checked everything. All seemed fine. Turned it back on and all was good. No more errors and I flew another 30 minutes.

    One thing to mention.... A couple days ago I changed my propellers. I still had another set of the factory props DJI sent with my drone so I decided to install them. I had a hard time getting one of the old ones off. I really had a difficult time it was on so tight. Finally I got some rubber gloves to hold the motor and it unscrewed.

    So my question is this. Do I possibly have a motor issue? Or was this just an app issue with DJI Go? Should I be worried a motor will go out? It's strange I get this message after changing the props 2 days ago and this was my first flight since changing them. I had probably flown 15 minutes before the error came up and another 30 minutes after it happened. Everything seems fine though.

    Ideas?


    Sent from my iPhone using PhantomPilots mobile app
     
  2. RedHotPoker

    Joined:
    May 3, 2015
    Messages:
    3,972
    Likes Received:
    1,365
    Location:
    Edmonton Alberta
    Which phantom do you have, Phantom 3 threaded blades or Phantom 4 with the clip on rotor blades?
    Are your firmware and app, the latest, & up to date?

    RedHotPoker
     
  3. Vertigo

    Joined:
    Jun 12, 2016
    Messages:
    499
    Likes Received:
    148
    Check your onboard flight log and see if the errors are in there. If the log is clean, as I suspect it will be, it probably was a software glitch caused by (re)starting the app in mid flight. If the errors do show in the log, double check your motors for any trouble