Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P camera doesn't send video and the upgrade fails

Discussion in 'Pro/Adv Discussion' started by Lastorri, Oct 17, 2016.

  1. Lastorri

    Joined:
    Sep 15, 2015
    Messages:
    4
    Likes Received:
    0
    Hi all,
    I have a P3 professional purchased in november 2015 here in Italy. I flew it only 5 times without ank kind of problem. Last flight was in june. two days ago I recharged both the controller and the battery but when I powered on the drone I discovered the camera doesn't send anymore the video signal. I tried to use different tablets but nothing changed. After this, since the fw was very old I tried to upgrade bot the controller now is at the latest release but the drone sistematically fails the upbrade. I tested using all the releases available on the DJI site. I tried alsto to reformat the sdcard... i tried also a different sdcard. nothing! the camera doesn't send the video. Now the djgo declares all the platform is upgraded but the upgrade process still finishes with a indefinite DDDDDDD sound and the text log reports only upgrade FAILS and the video is absent...

    Any suggestion ?
     
  2. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Reformat the SD card, if that doesn't work try a different SD card

    Sent from my SM-N920V using Tapatalk
     
  3. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Also make sure that the firmware you're putting on the aircraft matches the one on the remote

    Sent from my SM-N920V using Tapatalk
     
  4. Lastorri

    Joined:
    Sep 15, 2015
    Messages:
    4
    Likes Received:
    0
    I already formatted several times and changed the sdcard. I tried also with older versions but the result is the same: the upgrade fails:
    Here you can find the log of the last three trials:
    [00013490]========== remo-con disconnect. boot(15) ============
    [00013545]Packet [C:\P3X_FW_V01.09.0060.bin] detected, card sn [0x2850ca52].
    [00013598]Packet upgrade start...

    [00013663]Packet checking...
    [00013718]Packet vlink 01.09.0060 <-> 01.08.0080.
    [00013773]Record vlink 01.04.0010 <-> 01.03.0020 (flow = 0).
    [00013834]Done.

    [00013888]Version checking[1]...
    [00014086][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00014184][03 06][00] v2.4.20.18 -> v2.4.20.18
    [00014252][04 00][00] v1.44.0.0 -> v1.44.0.0
    [00014387][11 00][00] v1.8.0.0 -> v1.8.0.0
    [00014544][11 01][00] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support.
    [00014600][11 01][00] v1.8.0.0 -> v2.0.0.33
    [00014718][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00014833][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00014933][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00015039][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00027603][15 00][00] device not detected.
    [00027714][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00027864][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00027946][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00028001][01 00][00] v1.30.5036 -> v1.30.5036
    [00028077][01 01][00] v1.30.5036 -> v1.30.5036
    [00040634][08 00][00] device not detected.
    [00040726][09 00][00] v3.0.0.10 -> v3.0.0.10
    [00040780]Packet upgrade failed at version checking.



    [00013529]========== remo-con disconnect. boot(15) ============
    [00013583]Packet [C:\P3X_FW_V01.06.0040.bin] detected, card sn [0x2850ca52].
    [00013647]Packet upgrade start...

    [00013706]Packet checking...
    [00013765]Packet vlink 01.06.0040 <-> 01.05.0030.
    [00013827]Record vlink 01.04.0010 <-> 01.03.0020 (flow = 0).
    [00013882]Done.

    [00013938]Version checking[1]...
    [00014044][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00014144][03 06][00] v2.4.20.18 -> v2.4.10.7
    [00014206][04 00][00] v1.44.0.0 -> v1.41.0.0
    [00014342][11 00][00] v1.8.0.0 -> v1.7.15.1
    [00014446][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00014551][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00014651][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00014756][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00027325][15 00][00] device not detected.
    [00027432][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00027572][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00027643][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00027697][01 00][00] v1.30.5036 -> v1.26.4315
    [00027760][01 01][00] v1.30.5036 -> v1.26.4315
    [00040314][08 00][00] device not detected.
    [00040483][09 00][00] v3.0.0.10 -> v2.13.0.0
    [00040544]Packet upgrade failed at version checking.



    [00013414]========== remo-con disconnect. boot(15) ============
    [00013470]Packet [C:\P3X_FW_V01.07.0060.bin] detected, card sn [0x2850ca52].
    [00013535]Packet upgrade start...

    [00013594]Packet checking...
    [00013652]Packet vlink 01.07.0060 <-> 01.06.0040.
    [00013710]Record vlink 01.04.0010 <-> 01.03.0020 (flow = 0).
    [00013770]Done.

    [00013825]Version checking[1]...
    [00013936][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00014038][03 06][00] v2.4.20.18 -> v2.4.13.0
    [00014102][04 00][00] v1.44.0.0 -> v1.41.0.0
    [00014255][11 00][00] v1.8.0.0 -> v1.7.15.1
    [00014361][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00014459][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00014584][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00014716][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00027274][15 00][00] device not detected.
    [00027380][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00027523][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00027595][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00027660][01 00][00] v1.30.5036 -> v1.29.4920
    [00027717][01 01][00] v1.30.5036 -> v1.29.4920
    [00040285][08 00][00] device not detected.
    [00040376][09 00][00] v3.0.0.10 -> v2.13.0.0
    [00040437]Packet upgrade failed at version checking.



    [00012974]========== remo-con disconnect. boot(15) ============
    [00013029]Packet [C:\P3X_FW_V01.08.0080.bin] detected, card sn [0x2850ca52].
    [00013092]Packet upgrade start...

    [00013155]Packet checking...
    [00013219]Packet vlink 01.08.0080 <-> 01.07.0060.
    [00013279]Record vlink 01.04.0010 <-> 01.03.0020 (flow = 0).
    [00013338]Done.

    [00013394]Version checking[1]...
    [00013483][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00013583][03 06][00] v2.4.20.18 -> v2.4.14.5
    [00013646][04 00][00] v1.44.0.0 -> v1.44.0.0
    [00013784][11 00][00] v1.8.0.0 -> v1.7.15.1
    [00013896][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00014027][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00014132][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00014236][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00026894][15 00][00] device not detected.
    [00027011][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00027151][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00027221][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00027278][01 00][00] v1.30.5036 -> v1.30.5036
    [00027343][01 01][00] v1.30.5036 -> v1.30.5036
    [00039900][08 00][00] device not detected.
    [00039984][09 00][00] v3.0.0.10 -> v3.0.0.10
    [00040041]Packet upgrade failed at version checking.
     
  5. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Did you buy this new? or used? It's very strange that it is failing at version checking. You are downloading the correct file, the P3P firmware starts with P3X.
     
  6. Lastorri

    Joined:
    Sep 15, 2015
    Messages:
    4
    Likes Received:
    0
    Yes I purchased it new and I flew it without problems since june. The file (bin) is the P3X. Further, I have another P3P and I'm using the same BIN files I already uploaded on the second P3P without any problems. It is clear there is some failure in the first P3P... I asked the european support of DJI...