Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P Altitude Instability Video...

Discussion in 'Pro/Adv Discussion' started by vicdevore, Jun 7, 2015.

  1. vicdevore

    Joined:
    Jun 22, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Clermont, FL
    I love the camera quality on my P3P, but it seems to be hunting to maintain altitude. I disabled VPS and it does the same thing. Actually, this video is with VPS disabled. I also switched between modes during this video, including ATTI mode, with zero difference. I'm going to share this with my dealer, Aerial Media Pros, to see what they think. But, the consensus on the Facebook groups is that there is a problem. Any thoughts?

     
  2. keninvic

    Joined:
    May 15, 2015
    Messages:
    10
    Likes Received:
    1
    Location:
    Victoria, BC
    yes, grass is too long to provide a good echo, try same over pavement.
     
  3. vicdevore

    Joined:
    Jun 22, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Clermont, FL
    It does the same thing over pavement.
     
  4. vicdevore

    Joined:
    Jun 22, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Clermont, FL
    I did an IMU calibration and that fixed it... I was told it didn't need an IMU calibration unless the app said it was needed, but clearly it was needed because now it hovers in place the way it should.
     
  5. keninvic

    Joined:
    May 15, 2015
    Messages:
    10
    Likes Received:
    1
    Location:
    Victoria, BC
    good news, plus this will likely help someone else with the same problem.