Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced P3A nearly crashed and it seems RC signal is very poor

Discussion in 'Phantom 3 Help' started by JakeGreenField, Jan 1, 2016.

  1. JakeGreenField

    Dec 9, 2015
    Likes Received:
    Hi there,

    My P3A nearly crashed and it seems the signal was horrible. I'm in Florida with family and I just tried running a route with Litchi, but it wasn't working, so I decided to turn around and come home. All of a sudden, my P3A loses connection it seemed, and I regained enough just to have it not crash into my family and land safely (albeit a little roughly). Reviewing on HealthyDrones says the signal was horrible, but GPS was okay. Can anyone review the logs and tell me how to fix this or what went wrong? I lost downlink signal 12 times! I'm just confused and worried. I haven't had this issue before. Thanks!

    Log: HealthyDrones.com - Innovative flight data analysis that matters
  2. Badfinger

    Dec 26, 2015
    Likes Received:
    S/W OHIO
    I'm a rookie here but I'll try to help. First NEVER takeoff with just 42% battery! Second it looks like you changed modes about 10 back and forth from atti to gps in 2 minutes?? I looks like a wild flight and over water :( All I can say is get some more stick time in a open area or field and stay with GPS or P mode while practicing as it's more stable. Good luck.
    #2 Badfinger, Jan 2, 2016
    Last edited: Jan 2, 2016
    bobmyers likes this.