Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3A came with firmware 1.5.30+, can I go right to 1.8.80?

Discussion in 'Pro/Adv Discussion' started by ceteris_paribus, Jul 14, 2016.

  1. ceteris_paribus

    Joined:
    Jul 8, 2016
    Messages:
    13
    Likes Received:
    0
    So I've heard 1.5.30 isn't the greatest, can I just go straight to version 1.8.80? I don't want to load 1.9.60 just yet as it seems people are having problems.

    Edit * I guess my question is, do I have to install any versions before 1.8.80 first? I also need to update my RC
     
  2. Chasbro

    Joined:
    May 15, 2016
    Messages:
    82
    Likes Received:
    35
    Location:
    Houston Tx
    Pretty sure you can. I updated from 1.4 to 1.9.60 today. No problem, flies fine. Got some warnings about local grass airfields but they were just cautionary warnings.
     
  3. Blue Bird

    Joined:
    Jun 11, 2015
    Messages:
    615
    Likes Received:
    159
    Location:
    Dade County, Florida
    They latest FW is a All In One. Don't forget to update extra batteries if you have them.
     
  4. DroneX

    Joined:
    May 14, 2016
    Messages:
    15
    Likes Received:
    8
    1.5.30+ (with the plus sign) is actually 1.6.40 firmware. I have the same on my drone and have not upgraded and it works great.
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,866
    Likes Received:
    5,558
    Location:
    US
    No. Follow these instructions.