Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Pro won't enter multiple flight mode

Discussion in 'Pro/Adv Discussion' started by sclabrl, Sep 10, 2015.

  1. sclabrl

    Joined:
    Jun 22, 2015
    Messages:
    33
    Likes Received:
    8
    Anybody help?? Just updated new firmware to use new features (maybe I'll use em, maybe not). After the update was successfully downloaded, I followed the instructions to enter the multiple flight mode. After moving the toggle to F, nothing happens. No warning screen as it should, nor did the icon left of the GPS green bar show up.

    The ATTI mode works, but nothing happens in F mode. (I'm somewhat of a beginner and the ATTI mode scared the crap out of me and my bird drifted away!!!!)

    I've enabled multiple flight mode in the settings but after a few test flights am lost to what I'm doing wrong. Anybody point me in the right direction?

    Thanks for any help
     
  2. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    you have to be airborne before you can activate it, i.e. move the switch when your up there.
     
  3. dblagic

    Joined:
    Aug 22, 2015
    Messages:
    21
    Likes Received:
    4
    I have the same problem... I think I would reinstall new firmware if I figure it out how...
     
  4. Chuck Young

    Joined:
    Jun 25, 2015
    Messages:
    621
    Likes Received:
    192
    What happens when you put switch in "F" if multiple flight mode is OFF in settings? Do you get the message about enabling it? And are you in a hover?
     
  5. sclabrl

    Joined:
    Jun 22, 2015
    Messages:
    33
    Likes Received:
    8
    The pop up window at left side reminds me to select the multiple mode in settings. So I followed the warning and did it as told.
     
  6. sclabrl

    Joined:
    Jun 22, 2015
    Messages:
    33
    Likes Received:
    8
    Yes in hover about 175 feet
     
  7. sclabrl

    Joined:
    Jun 22, 2015
    Messages:
    33
    Likes Received:
    8
    I've been searching out for an threads or links but nothing....
     
  8. sergekouper

    Joined:
    Apr 20, 2014
    Messages:
    752
    Likes Received:
    128
    Location:
    London UK
    you probably tapped the new icon at the top of the screen ?
     
  9. sclabrl

    Joined:
    Jun 22, 2015
    Messages:
    33
    Likes Received:
    8
    No icon shows up. As the instructional video shows, when the user changed mode to F, a warning pop up window opens up. That doesn't open either.
     
  10. dblagic

    Joined:
    Aug 22, 2015
    Messages:
    21
    Likes Received:
    4
    have you installed frimware with formatted sd card?? I didn't... maybe is that problem for us
     
  11. sergekouper

    Joined:
    Apr 20, 2014
    Messages:
    752
    Likes Received:
    128
    Location:
    London UK
    Have you updated DJI Go to 2.2.0 ?
     
    #11 sergekouper, Sep 10, 2015
    Last edited: Sep 10, 2015
  12. Chuck Young

    Joined:
    Jun 25, 2015
    Messages:
    621
    Likes Received:
    192
    If I were you I would install the app from the store.
     
  13. dblagic

    Joined:
    Aug 22, 2015
    Messages:
    21
    Likes Received:
    4
    I have updated GO app after the firmware... do you think that it could be the problem???
     
  14. sergekouper

    Joined:
    Apr 20, 2014
    Messages:
    752
    Likes Received:
    128
    Location:
    London UK
    I did the same, updated the app at the end...
     
  15. sclabrl

    Joined:
    Jun 22, 2015
    Messages:
    33
    Likes Received:
    8
    I will try reinstalling the go app. Thanks guys for the help; I'll be back
     
  16. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    I noticed my app showed a screen about the new options, which made it look like it had updated, but it needed doing manually because I deliberately had auto-updates turned off.
    It won't hurt to delete it and get a new install rather than update what you have.
     
  17. dblagic

    Joined:
    Aug 22, 2015
    Messages:
    21
    Likes Received:
    4
    Have you solved the problem???
     
  18. Bronson

    Joined:
    Jul 8, 2015
    Messages:
    17
    Likes Received:
    1
    Make sure you installed the correct firmware for your phantom and always calibrate the IMU after successfully installed the fw update.
     
  19. dblagic

    Joined:
    Aug 22, 2015
    Messages:
    21
    Likes Received:
    4
    I have solved the same problem... downgrade and do upgrade again... in advanced setting disable multiple flight mode and than on hover when you switch to F mode it will ask you to enable and than ioc menu will appear...
     
  20. Avi Zigdon

    Joined:
    Sep 11, 2015
    Messages:
    1
    Likes Received:
    1
    I have the same problem.
    Disable multiple flight after installing the app, then enabled it during flight and it worked.
    The problem is, after trying to fly again, it STOPPED working. and you have to repeat the process again.
     
    JBG likes this.