Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 pro Firmware 1.5 beta??

Discussion in 'Pro/Adv Discussion' started by jimmybonsaville, Apr 15, 2016.

  1. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Hey guys. Well after day 1 purchase I've finally updated to 1.4 and all went well and it flys great so far. The only drawback was I thought 1.4 contained the new video modes...bitrate and 2.7k but looks like it doesn't. I've read all the nightmares regarding 1.5 being buggy with vibrations and battery problems and Nfz being snuck in. I also remember a post from people still using a 1.5 beta that had non of the above problems?

    Does anybody have any links and or feedback on this? I really dont want to jump to 1.6 and have to deal with the nfz. I am a qualified pilot and have friends loosing work because of the nfz authorization hold ups.

    Thanks
     
  2. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
  3. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Hi Rob thanks but I already have 1.4. It's the 1.5 beta with the new camera options that I need.
     
  4. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    1.4.3 which shows as 1.4 has the camera options and the poi etc.
     
  5. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Ah really!? So this has 2.7k and the improved bitrate? That's great if so!
     
  6. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    yes it has the lot but you may have to update rc as well (not sure).

    also my go app older one.
     
  7. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Ah it's for the advance I'm using a pro
     
  8. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    i also have the pro firmware, which version do you want ?

    I can put it in dropbox.
     
  9. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Thanks. I have managed to find 01.050011 which I think is the beta? Just trying to see if it's worth upgrading or not
     
  10. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    not sure, the general release of 1.5 had major problem with critical battery warning notifications and landing so be careful.
     
  11. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Yea that's why I don't want to jump up to 1.5 but I've read on here that the beta didn't have these problems? Just trying to see if anyone has feedback. Really would like the new 1080p bitrate and 2.7k but not all the problems that come with it ha
     
    #11 jimmybonsaville, Apr 15, 2016
    Last edited: Apr 15, 2016
  12. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,124
    Likes Received:
    1,652
    Location:
    San Francisco, CA
    Don't go for FW 1.5. Even DJI doesn't recommend it.

    Stay with what you have. You will have 2.7k video capturing. What's the go app version you have? I doubt if you are free of NFZs.

    Once you started upgrading, you will land up at the latest FW.
     
  13. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    I did read 1.5 beta didn't have these problems. I'm using 2.4.3 like suggested on here. There is no option for 2.7k?
     
  14. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
  15. jimmybonsaville

    Joined:
    Apr 24, 2014
    Messages:
    66
    Likes Received:
    7
    Yes 2.7k is only on 1.5 that has issues and I'm using 1.4 but down want to have to update to 1.6... Nightmare ha
     
  16. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Looks like you will have too stick where you are.