Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware P3 Pro DJIGo app wont update RC firmware

Discussion in 'Firmware' started by Mau Fdz, Aug 16, 2016.

  1. Mau Fdz

    Joined:
    Aug 16, 2016
    Messages:
    5
    Likes Received:
    0
    Hi guys, having a hard time updating my RC. I tried looking for similar issues, could not find a similar thread.

    I have a P3 Pro, bought last december, worked great until a couple of weeks ago when I upgraded, bird and batteries are OK, the RC wont update. It goes through the whole process, says it completed the upgrade and to reboot the RC, when I turn it back on, again it says it needs to be updated. It also says that the firmware version of RC is Unknown.

    DJI Go app version 2.8.6
    Firmware version 1.6

    Now I have another issue, when I connect the DJI Go app it identifies the RC as a P4 instead of a P3 Pro.

    I have tried everything:
    - Re-installed the DJI Go app several times
    - Did an RC reset
    - Re downloaded the firmware
    - Tried using the SD Card and an USB

    I am worried if I fly that I will have problems, nothing works, tried DJI support, clueless, please help.

    Thanks,

    Mau
     
  2. Blue Bird

    Joined:
    Jun 11, 2015
    Messages:
    615
    Likes Received:
    159
    Location:
    Dade County, Florida
    Have you tried another USB cord?
     
  3. Mau Fdz

    Joined:
    Aug 16, 2016
    Messages:
    5
    Likes Received:
    0
    I have not, I have tried using different SD cards, I will try the USB cord
     
  4. Mau Fdz

    Joined:
    Aug 16, 2016
    Messages:
    5
    Likes Received:
    0
    I have finally resolved my RC issue, apparently the problem is between the iPhone 6S and the DJI GO App, I was about to ship my RC to DJI repair when I gave it a final try but using my iPad Air instead of my iPhone 6S, connected my RC and surprise, everything was OK, no update warning, nothing. I checked in the About section for the firmware version of my RC and it was the correct one (version 1.6).

    Connected my P3 Pro and everything seemed to be OK, flew it and all went smoothly.

    I have created another thread explaining this issue in detail and have sent these findings to DJI support to see what they can investigate.

    Best regards, Mau