Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Adv FW 1.4 to 1.7

Discussion in 'Pro/Adv Discussion' started by davemks, Mar 16, 2016.

  1. davemks

    Joined:
    Mar 10, 2016
    Messages:
    2
    Likes Received:
    0
    I am confused, can I update directly from 1.4 to 1.7 or do I need to go through each FW update 1.4 1.5 1.6 then to 1.7 Thanks
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,096
    Likes Received:
    5,623
    Location:
    US
    You can go from 1.4 to 1.7.
     
  3. Meist21

    Joined:
    Jan 11, 2016
    Messages:
    39
    Likes Received:
    8
    But if he does that he can only go back to 1.6 and not all the way to 1.4 is that correct? Asking more for myself.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,096
    Likes Received:
    5,623
    Location:
    US
    You can only downgrade one version. So, if you install 1.6, you can downgrade to 1.5. If you install 1.7, you can downgrade to 1.6. Etc.
     
  5. davemks

    Joined:
    Mar 10, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks for your help!
     
  6. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    So far I am sticking with 1.4.

    Not sure there any real advantages of changing to 1.7
     
  7. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,234
    Likes Received:
    915
    Location:
    Indy, USA
    Absolutely! There is people out there that would almost give their left leg to be back on 1.4.
     
  8. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    I'm on 1.5, don't do that. Update to 1.5 that let you come back to 1.4 if you want.
     
    #8 StevenQX, Mar 19, 2016
    Last edited: Mar 19, 2016
  9. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    1.5 has battery measurement problem.

    Even DJI say update (or downgrade on that version)
     
    StevenQX likes this.
  10. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Really? What kind of issue?
     
  11. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    The battery voltage is read incorrectly and you can get critical voltage error. (when battery is ok) and it will auto land.

    It was here in multiple threads after it was released.
     
  12. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    I would strongly suggest you move back to 1.4
     
    StevenQX likes this.
  13. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Well i'm not on the "final" 1.5 but on the first one releasede 1.5 for developers, but i think i'll move back to 1.4 thanks.

    The one i've is P3S_FW_V01.05.0011.bin
    The official is P3S_FW_V01.05.0030.bin

    Maybe is not the same about battery issues?
     
  14. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun