Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 4k with no video or app

Discussion in 'Standard/4k Discussion' started by Ted4797, Jul 30, 2016.

  1. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    981
    Likes Received:
    157
    Location:
    Florida
    I have a P3 4k with no video output at all. I don't even get a green light on the camera. I cracked it open and found the camera wire frayed and the wires touching each other. I replaced the wire but it still doesn't power the camera. I installed a new camera but it didn't help. I think the MB is bad now. How do I figure out the part number so I can order a new one. The only board I can find is part #123. It looks the same but says it is for the older motor and I have the new motors. I tried Hunch but he does not reply to my messages. Anyone??
    It has never been crashed.
     
  2. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    981
    Likes Received:
    157
    Location:
    Florida
    Amazing that nobody knows. Maybe I need to join a different group
     
  3. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    981
    Likes Received:
    157
    Location:
    Florida
  4. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    981
    Likes Received:
    157
    Location:
    Florida
    Lol. That was a waste of time


    Sent from my iPhone using PhantomPilots
     
  5. captainmilehigh

    Joined:
    Apr 4, 2016
    Messages:
    812
    Likes Received:
    381
    Location:
    Northeast Florida
    I'd try hunch again at uavrepairshop.com. He's probably busy and it got by him. He's always gotten back to me even if I PM him.

    I'm sure he'll help you get back flying.


    Sent from my iPad using PhantomPilots