Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P2v2+ Gimbal unresponsive, tried muliple solutions no changes.

Discussion in 'Phantom 2 Vision + Help' started by Weiz, Sep 15, 2015.

  1. Weiz

    Joined:
    Sep 15, 2015
    Messages:
    3
    Likes Received:
    0
    This is the problem i have after a crash. Changed ribbon cable and circuit boards (the 2 small). I'm running out of ideas. Anyone can help?


    Video of the issue.
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,923
    Likes Received:
    5,573
    Location:
    US
  3. Desert Dave P

    Joined:
    Aug 29, 2015
    Messages:
    30
    Likes Received:
    1
    i had exactly this when i replaced the ribbon cable with one from ebay. out of frustration i got a pair form amazon and did it again and got it working. Not saying 100 percent thats it but it looks very much like what i had. Dave
     
  4. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    Weiz,
    when you put the camera case part back on when reinstalling the cable
    how did you slide the case on the pitch shaft?
    where the screw goes in with the half moon shaft looking at you or the flat part looking at you.
    it matters which way it goes on.

    also your LED on the gimbal is blinking red so something is not right.
    Dave might be right. faulty gimbal cable is possible.
     
  5. Weiz

    Joined:
    Sep 15, 2015
    Messages:
    3
    Likes Received:
    0
    I don't recall about where the flat part of the half moon goes, i followed a video, buy i'm gonna reopen it and check. Also i bought another ribbon cable, so i will be swapping it, in case it's that "simple". Thank you for your help, guys.
     
  6. Angus Macsac

    Joined:
    May 21, 2014
    Messages:
    112
    Likes Received:
    15
    Location:
    Ontario, Canada
    I used this video .... on youtube to replace my ribbon cable and where it got to the part (about 27 minute mark) to loop the cable around the shaft and under itself I followed what the guy was showing but when done the looping and I went to connect the plug to the socket at the camera board I noticed that the gold connectors on the plug were upside down in relation to the contacts in the socket on the camera board.
    After checking with another video on youtube I reasoned that the ribbon had been wound in the wrong direction in the first video. Reversing the loop around the shaft brought the contacts on the plug into the correct orientation with the socket contacts.
     
  7. Django Reborn

    Joined:
    Oct 24, 2015
    Messages:
    5
    Likes Received:
    0
    Hello bro... How's your drone? Mine got the same problem... Have you save it already? Will really appreciate for some help