Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P2 V+ after crash diagnosis

Discussion in 'Phantom 2 Vision + Help' started by Bkingnorth, Aug 18, 2015.

  1. Bkingnorth

    Joined:
    Aug 18, 2015
    Messages:
    3
    Likes Received:
    0
    I have a P2V+ that had a tumble from about 8'. I didnt break anything visually. I have re calibrated the IMU and gone through the battery of what-ifs. I have put a brand new DJI battery in it and still the same. It wont connect to GPS and continues to flash yellow (slow). when i try to start the motors it just flashes red 5 times and nothing.... Ideas?
     
    #1 Bkingnorth, Aug 18, 2015
    Last edited: Aug 18, 2015
  2. robsquad

    Joined:
    Dec 4, 2014
    Messages:
    962
    Likes Received:
    422
    Location:
    Wolverhampton, UK
    will it fly in atti mode ?
     
  3. Bkingnorth

    Joined:
    Aug 18, 2015
    Messages:
    3
    Likes Received:
    0
    No it does the same.. 5 red flashes when I try to start the motors
     
  4. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Plug it into the PC. A warning should appear.
    If you get into a bump, please redo an ADVANCED IMU calibration. This will realign the sensors.

    Also..
    The other reason why motors don't start is that the GPS module cant be detected. The cable can come loose from a bump (I think the V3 has the revised plug).
     
  5. Bkingnorth

    Joined:
    Aug 18, 2015
    Messages:
    3
    Likes Received:
    0
    Did a advanced Imu calibration. No warnings in the software. I checked the plug and it appears to be secure. Same problem exists