Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P2 losing contact with transmitter ...help!

Discussion in 'Phantom 2 Help' started by weephillie, May 28, 2015.

  1. weephillie

    Joined:
    Mar 12, 2014
    Messages:
    17
    Likes Received:
    0
    Location:
    Sunderland, UK
    Recently had a new Zenmuse H3-3D gimbal fitted and upgraded to the current transmitter. It is the original P2 which came with the transmitter that had the gimbal control on the back.

    When i am flying the P2 keeps going into failsafe mode and returns to home. It doesn't even let me recover by switching to Atti mode. I have noticed a few times that when I go to start up the transmitter needs to be paired up again using the red/green button underneath.

    I am desperate to get this right as we have a job overseas on Tuesday and had planned to take the P2 with us. Has anyone else had the same problem and could point us in the right direction please? The compass has been calibrated, the battery is fully charged and as far as I'm aware all the software is up to date.

    HELP!
     
  2. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,104
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Go into the P2 software and check your distance limits. If your still in Phantom mode there isn't an ATTI in the center position on S1. In order to have ATTI you have to switch from Phantom to Naza then S1 is GPS, ATTI and Failsafe if you set it up in the software.
     
  3. weephillie

    Joined:
    Mar 12, 2014
    Messages:
    17
    Likes Received:
    0
    Location:
    Sunderland, UK
    Thanks I will try that and see if that does the trick.
     
  4. weephillie

    Joined:
    Mar 12, 2014
    Messages:
    17
    Likes Received:
    0
    Location:
    Sunderland, UK
    Checked all settings and they are fine. Re-calibrated everything and still have a problem. However I have identified what the problem is. The controller is becoming unpaired during flight. This is why i have no control over the P2 during return to home. Once landed it needs to be paired again. Would really appreciate a solution ...anyone?