Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Only 300 feet on WiFi extender before signal loss?

Discussion in 'Phantom 2 Vision Help' started by jgerlitz, Jul 3, 2014.

  1. jgerlitz

    Joined:
    Jun 5, 2013
    Messages:
    34
    Likes Received:
    0
    Just purchased a Phantom 2 Vision. This is my second Phantom but first of the Vision model.

    I followed all the instructions perfectly and get a strong and clear video feed to my iPhone 5s.

    However, after just after 300 feet it seems I lose the signal and the video feed cuts out.

    This happens in all directions. I am flying line of sight and in 90% open fields. Only a few light poles etc around.


    Any ideas on why this might be? Any quick tips to help correct it?


    I'm hoping it doesn't mean I have a faulty unit.


    Thank you,



    Jeff
     
  2. HML48

    Joined:
    Feb 11, 2014
    Messages:
    20
    Likes Received:
    0
    I and a number of others have had similar experiences.

    Here is an abbreviated version of the laundry list of things that might be wrong:
    1 Are you are running compatible versions of everything?
    2 Have you have selected the lowest data rate for the refresh?
    3 Have you turned off any features on your smart phone that search for and connect to better performing WiFi sources?
    4 Are you are pointing the repeater's antennas at the phantom?
    If the answer to all the above is yes, then you might have a lemon of a repeater.

    My advice is don't try to fix this yourself or do any of the antenna mods on a poorly performing device but sent it back for replacement. I voided my guarantee and ended up replacing the repeater on my own.

    Harry