Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

one propeller stutter (but never used propguards!)

Discussion in 'Phantom 2 Vision + Help' started by winningshot, Jul 25, 2014.

  1. winningshot

    Joined:
    Jun 8, 2014
    Messages:
    7
    Likes Received:
    0
    Hey guys,
    one fine day last week the rear right propeller of my Phantom 2 Vision + started stuttering, that is spinning slowly, stopping, even going backwards a little. It ONLY does this with a plastic (stock) propeller mounted. If I take all propellers off then all four seem to spin just fine at the same speed, responding to the remote control.

    When it happened and I was in desperation I manhandled it a bit, that is: I grabbed the motor arm and pushed and twisted a little. Then it suddenly worked and I did a perfect flight. But the next day: same problem. But this time I can't get it to work by harassing it.

    I opened the case and all seems fine. Moved the wires a bit to see if it's a bad solder connection, but doesn't seem to make a difference.
    Just to clarify: I have never attached propguards and in fact never before messed with it in any way and never crashed. It just happened "by itself"!
    Does anyone have any ideas?? Thanks in advance!
    Mirko
     
  2. winningshot

    Joined:
    Jun 8, 2014
    Messages:
    7
    Likes Received:
    0
    Actually I do find that even without propeller, that motor is easier to stop with my fingers, even though it appears to spin as fast as the others.
     
  3. AAG201

    Joined:
    Jul 22, 2014
    Messages:
    4
    Likes Received:
    0
    Hey - What did you ever come up with on this issue? I had the exact same problem. I replaced the ESC on that corner and it worked fine again, but I could tell it still had low torque at that corner. Now, I have been having new flight issues today so I'm curious if it is related. In heavy wind and when I fly fast then turn rapidly, the Phantom (P2V+) will stall and go into a tail spin and then crash. I crashed 4 times today because of this (all below 30 feet). I'm curious if my replacement ESC has a bad connection or if there is a bigger issue.
     
  4. winningshot

    Joined:
    Jun 8, 2014
    Messages:
    7
    Likes Received:
    0
    Hi there, I haven't found a solution yet. I emailed DJI and they replied asking for a video. I've just uploaded it to vimeo:
    https://vimeo.com/101792836
    Thanks for the info on your issue. At least it makes me think that I can fix it somehow. But it stinks that yours is crashing. They're darn sensitive devices. I'll let you know what I find out.
     
  5. winningshot

    Joined:
    Jun 8, 2014
    Messages:
    7
    Likes Received:
    0
    ESC was faulty. Works now.