Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

One of LED underneath motor arm is broken

Discussion in 'Phantom 2 Vision + Discussion' started by zincsoldier, Mar 17, 2015.

  1. zincsoldier

    Joined:
    Mar 17, 2015
    Messages:
    211
    Likes Received:
    31
    Hi,
    I am very new to this and would love to hear from everyone's experience on this hobby :) my experience was so awesome until one day I crashed it into a tree and all went south from there. However, I have managed to do a shell replacement by myself thanks to the Internet. Everything is perfect now except for a broken camera gimbal and one LED light underneath one arm is not litting. Unfortunately, the unit is fine after the test flight (about 3 time). I suspect it might be a bad ESC I am having in one arm or is it just the LED? I did all preflights check with GPS signal on, I can't see how many satellites available as The camera gimbal unit was broken and I am flying it without the camera gimbal. However, I did wait for a good 5 minutes before flights now to make sure it acquires enough GPS lol. I inspect the ESC in that particular arm but no burned IC or loose connection on that ESC. The unit is flying perfect with stable hovering so I am wondering what is the real problem :( Right mow I am still saving for a new camera gimbal unit. Please advise me on ehat I could do wiht this problem. Thanks heaps guys !!!
     
  2. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,745
    Likes Received:
    1,092
    Location:
    Long Island, NY
    there are instructions in the forum on how to get telemetry data on your screen w/o a camera and gimbal.

    regarding saving for a new gimbal, send users Hunch or Burlbark a message w/ a picture of the gimbal. Both of them have repaired plenty of bent gimbals, obviously cheaper than buying new.

    irt the LED, i'd imagine its just broken. if it were an ESC issue, I'd think you wouldn't be able to fly very well. Just conjecture.
     
  3. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    The LEDs under the ESC are all wired in series. If one of them gets knocked loose a bit, then they all go out.
    You can unscrew the ESC in question and examine the LED contacts. If you have a small-tipped soldering iron,
    you may be able to solder a loose contact back in place.
     
  4. Mori55

    Joined:
    Feb 13, 2014
    Messages:
    1,993
    Likes Received:
    6
    Location:
    NJ-USA
    I would just replace the esc.
     
  5. zincsoldier

    Joined:
    Mar 17, 2015
    Messages:
    211
    Likes Received:
    31
    Thanks so much guys for the advices. By the way Im from Sydney, Australia. Do you know any guys based in my area for bent gimbal and camera fixing? I am taking my unit now for ESC replacement. Good morning from Sydney!!! :)
     
  6. eseckinger

    Joined:
    Feb 13, 2015
    Messages:
    231
    Likes Received:
    55
    Just did a shell replacement myself about a week ago and had a similar issue. Try This first, On the LED that is out turn your bird on with the top off, props off and esc screws out (one that the led is out) . Try putting pressure on the last led light closest to the motor and see if the lights come on. Actually press on the led itself.
     
  7. zincsoldier

    Joined:
    Mar 17, 2015
    Messages:
    211
    Likes Received:
    31
    Cool it is working now but sometimes it still doesnt work lol. There s something seriously wrong about it. Anyway I guess I have to continue monitoring it. Thanks for your help. Save me from a new ESC :)
     
  8. eseckinger

    Joined:
    Feb 13, 2015
    Messages:
    231
    Likes Received:
    55
    wrong or right here is what I did to solve it. Take a very thin piece of clear plastic and place it between the shell and that last LED light. Once you tighten it all down it will work because of the pressure.
     
  9. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    16
    Australia is no problem to ship to. I just declare on the customs for return goods repair. I send repairs all over the world. Pm me some contact info and than I can get some pictures and try to give you a ballpark estimate.

    Jeremy
     
  10. zincsoldier

    Joined:
    Mar 17, 2015
    Messages:
    211
    Likes Received:
    31
    Hi Jeremy,
    Here is the gimbal picture
     

    Attached Files:

  11. zincsoldier

    Joined:
    Mar 17, 2015
    Messages:
    211
    Likes Received:
    31
    And the camera completely fell apart
     

    Attached Files:

  12. zincsoldier

    Joined:
    Mar 17, 2015
    Messages:
    211
    Likes Received:
    31
    Please have a look Jeremy and let me know if it is fixable. Thanks!