Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

One Motor Spinning Sporadicly

Discussion in 'Phantom 1 Help' started by TacoGrease, Jul 26, 2013.

  1. TacoGrease

    Joined:
    Jun 15, 2013
    Messages:
    10
    Likes Received:
    0
    Hi all,

    Just installed the T-motor AntiGravity motors (MN2214), and, unfortunately, only 3 out of the 4 spool up/idle properly - one of the motors stops and starts, though once I up the throttle this phenomenon stops.

    During the first test flight after the install, the circuit board for the motor in question began smoking (not the motor itself). I killed it as quickly as possible, but I fear I may have cooked something (hence the issue).

    Thoughts?

    Is there a place to buy replacement circuit boards for the motors?
     
  2. Driffill

    Joined:
    Jun 14, 2013
    Messages:
    529
    Likes Received:
    3
    It sounds like a loose connection, or possibly a cold solder join!
     
  3. Audaciter

    Joined:
    Mar 18, 2013
    Messages:
    724
    Likes Received:
    2
    Location:
    Sunnyvale, California, USA
    You will have to replace the ESC, as the smoke probably came from one of the fets.

    It is important not to solder the wires so that they lay across the fets. I found that out the hard way, as my esc caught fire.
    Solder the wires so that they stand upright as much as possible.

    Esc's are one of the least expensive parts, so not too much damage done.

    You will enjoy the Anti-Gravity motors.
     
  4. TacoGrease

    Joined:
    Jun 15, 2013
    Messages:
    10
    Likes Received:
    0
    Ah, bummer. I've ordered a new one, hoping to get back in the air soon.

    Thank you, Audaciter!