Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Ok, upgraded to 1.6 and feel like an idiot....

Discussion in 'Pro/Adv Discussion' started by Gsujeff55, Jan 14, 2016.

  1. Gsujeff55

    Joined:
    Oct 7, 2015
    Messages:
    116
    Likes Received:
    32
    any reason to not upgrade the RC? everything worked fine on 1.3.2 but i got tired of the nasty red triangle and I glanced at something that said 1.6 fixed the battery voltage issue so i went ahead and did it. only thing left is RC.

    also, how do i see my DJI GO version? can't find it for the life of me. haven't updated it in months though.
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    The DJI GO version is displayed in the "About" section of the DJI GO app.
     
  3. Gsujeff55

    Joined:
    Oct 7, 2015
    Messages:
    116
    Likes Received:
    32
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    2.5 is the current version.
     
  5. Gsujeff55

    Joined:
    Oct 7, 2015
    Messages:
    116
    Likes Received:
    32
    Will I have better luck getting back to 1.3.2 or 1.4 if I don't update the RC or the app?
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    According to DJI, you can only go back to 1.5 after installing 1.6. And, 1.5 is not the best release to use due to the battery issues that have surfaced. I'd stay at 1.6 if I was you.
     
  7. SouthernPhantom

    Joined:
    Jun 10, 2015
    Messages:
    315
    Likes Received:
    122
    I've always updated to the latest versions of everything and never had a problem.
     
  8. Apilot101

    Joined:
    Jan 6, 2016
    Messages:
    259
    Likes Received:
    55
    I can get the RC and the App back (downgraded) but not the quad yet.
     
  9. low_budget

    Joined:
    Dec 20, 2015
    Messages:
    34
    Likes Received:
    9
    Location:
    Missouri, USA
    why can't I downgrade to 1.4 if 1.5 is confirmed defective by Dji?

    this is making me mad. I HATE v1.6 and its dumbed down flight characteristics

    I only tried v1.6 because the official release notes said 1.6 can be downgraded to 1.5 and 1.5 said I could downgrade to 1.4

    yeah, not if you didn't know better and dji never said anywhere you can only go down one version!

    anyone want to buy a phantom 3 advanced with the horrible v1.6? the firmware update knocked $200 off the value in my opinion.

    I don't trust dji anymore
     
  10. Gsujeff55

    Joined:
    Oct 7, 2015
    Messages:
    116
    Likes Received:
    32
    exactly. i wonder if any retailer still has a p3a or p3p from october sitting on the shelves
     
  11. ParsnipHysorter

    Joined:
    Sep 28, 2015
    Messages:
    220
    Likes Received:
    174
    Agreed. I deeply regret my upgrade from 1.4 to 1.6 (skipping 1.5). My beloved P3 flies like a slug now. My only hope is that in a future firmware they rethink how they are handing power optimization, but I won't hold my breath.