Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

"Not DJI Intelligent Battery !" - Solid Red Help!

Discussion in 'Phantom 2 Discussion' started by maxscottdog, Jan 23, 2014.

  1. maxscottdog

    Joined:
    Jan 3, 2014
    Messages:
    19
    Likes Received:
    0
    Location:
    Towcester, UK
    Hi All,

    P2, H3-2D Gimbal, Fatshark 250mw.

    Got iOSD and installed, once powered updated with latest firmware. Power recycle.
    Now sat with solid red lights on rear and P2 Assistant saying "Not DJI Intelligent Battery!" This statement shows on both my batteries. Genuine P2 and batteries. Prior to this all working well. Additionally Gibal not working showing red flashing light. Also upgrade area now not showing all components.

    Please see pictures.

    Your help as a community is greatly appreciated.
     

    Attached Files:

  2. tosi

    Joined:
    Jan 15, 2014
    Messages:
    35
    Likes Received:
    0
    Location:
    Gol, Norway
  3. maxscottdog

    Joined:
    Jan 3, 2014
    Messages:
    19
    Likes Received:
    0
    Location:
    Towcester, UK

    Yes I had seen this however it did not work as I am missing the P330CB Board, battery and GPS versions. This makes it impossible via the software to essentially reinstall everything. It's is like they have just disappeared!!

    Still looking for an answer but appreciate the post
     
  4. maxscottdog

    Joined:
    Jan 3, 2014
    Messages:
    19
    Likes Received:
    0
    Location:
    Towcester, UK
    Update, this has now gone back to retailer for support. Raised with DJI and DJI Support just got the pass it back to retailer response.
     
  5. Scott Morris

    Joined:
    Mar 16, 2016
    Messages:
    5
    Likes Received:
    0
    I have two OEM Intelligent batteries,Updated firmare on aircraft and remote control,one works fine,the other gives me a warning (NON-DJI Intelligent Battery Detected Aircraft Flight Prevented)Any help would be appreciated.
     
  6. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,107
    Likes Received:
    405
    Location:
    Commerce Twp,MI
    [Check the batteries two copper pads right under the charging terminals and make sure they are clean also make sure the spring loaded info pins are clean as well and functioning. Also check that the battery is fully seated.