Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Not creating enough lift, software problem?

Discussion in 'Phantom 2 Vision + Help' started by Inspiration, Apr 7, 2015.

  1. Inspiration

    Joined:
    Mar 20, 2015
    Messages:
    3
    Likes Received:
    0
    I had my PV2+ for almost half a year. Never had any problems with it until I updated to the current software using the DJI Assistant application. Now when I try to start the drone, it can not fly or lift off the ground. I think the motors are not spinning fast enough than before, as far as I know the motors are in good condition and working properly.

    Current Application Software
    Assistant Software v3.8

    I have not update to the Main Controller Firmware* v3.12, but the problem happen before the update.


    Edit: More info
     
    #1 Inspiration, Apr 7, 2015
    Last edited: Apr 8, 2015
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,770
    Likes Received:
    5,524
    Location:
    US
    Did you calibrate the remote controller and IMU after installing the firmware? You should always do both calibrations after an upgrade.
     
  3. AzDroner

    Joined:
    Apr 5, 2015
    Messages:
    125
    Likes Received:
    14
    In the app, are you in "mode 2"? You might take a look and be sure that you are.
     
  4. Inspiration

    Joined:
    Mar 20, 2015
    Messages:
    3
    Likes Received:
    0
    I can check this weekend, will it say mode 2 or is it a configuration of colored lights. Also, how would the drone possible change modes?

    Thanks for the response
     
  5. edmcmeans

    Joined:
    Jan 10, 2015
    Messages:
    35
    Likes Received:
    1
     
  6. edmcmeans

    Joined:
    Jan 10, 2015
    Messages:
    35
    Likes Received:
    1
    In the assistant software there will be a box to check, actually there is a mode 1 box and a mode 2 box. You want mode 2. If you're in mode 1, The right stick will have the functions that your left stick should have. Try to lift off by pushing your right stick up, if it does, you're in mode 1.
     
  7. Inspiration

    Joined:
    Mar 20, 2015
    Messages:
    3
    Likes Received:
    0
    Yes I calibrated both, but the problem still persisted.
     
  8. AzDroner

    Joined:
    Apr 5, 2015
    Messages:
    125
    Likes Received:
    14
     
  9. AzDroner

    Joined:
    Apr 5, 2015
    Messages:
    125
    Likes Received:
    14
    Try to lift off using the right stick.