Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No link with remote following crash

Discussion in 'Phantom 2 Help' started by qtluong, Feb 26, 2014.

  1. qtluong

    Joined:
    Feb 25, 2014
    Messages:
    18
    Likes Received:
    0
    Phantom 2 (non-vision) had bad crash.

    The link indicator light was always steady red (no 2.4GHz signal detected) even with remote on, so I thought that maybe RX broken. I plugged in a new RX.

    Now when I press on the link button it does blink red, but after I release it, the link indicator does not turn to green.
    Instead, with remote on, it is off.
    If the remote is off, it goes (correctly) to steady red.

    Thinking of maybe trying another NAZA MC, any other better ideas ?
     
  2. mikeydaddio

    Joined:
    Feb 4, 2014
    Messages:
    166
    Likes Received:
    0
    Noticed you didn't get any replies so I thought I'd chime in. This may not be relevant but on my Phantom 1.1.1, it does as you describe. When I press the link button it flashes red but when I release it, it goes out. I thought that was normal: when it goes out, it has a connection. If I turn my transmitter off, it goes solid red.

    The only time mine is green is when I have it connected via USB to the Assistant software.

    Mike
     
  3. qtluong

    Joined:
    Feb 25, 2014
    Messages:
    18
    Likes Received:
    0
    Thanks Mike, unfortunately I have no connection.
     
Loading...
Similar Threads - link remote following Forum Date
Remote only has 1 blinker on left side/no charge. Phantom 4 Help Yesterday at 11:05 AM
Red lights blinking when I turn on the remote Phantom 2 Help Tuesday at 4:41 PM
A New Datalink 3 Remote from DJI. General Discussion Apr 10, 2017
Relinking phantom 3 4K with Remote controller... Standard/4k Discussion Apr 1, 2017
Remote controller - blink / beep codes ? Standard/4k Discussion Mar 24, 2017