Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No light on AVL58 transmitter + iOSD Mini blinking

Discussion in 'Phantom 2 Help' started by Engan01, Jan 10, 2014.

  1. Engan01

    Joined:
    Jan 6, 2014
    Messages:
    37
    Likes Received:
    0
    Hi!

    I just got my Phantom 2 and I have installed the zenmuse gimbal. Works great so far!

    My next step is to install a FPV system using the zenmuse gimbal (GoPro 3+) with a iosd mini and the dii avl58 transmitter.
    I have connect everything exactly like the manual, but I still don't get my dii avl58 transmitter to fire up. it's completely dead. Is there something I should do to activate the "outlet power" cable that comes standard with the Phantom 2, or anything else?

    My iOSD is blinking green, witch means there is some kind of data communication, but since the avl58 transmitter dosen't seam to fire up I can't get it to work (there is no flashing green lights on it).

    Could this problem be solved by a firmware upgrade? I hava tried to upgrade my iosd mini but I notices it only works on a windows machine (sucks big time).

    Looking forward what you guys are saying...
     
Loading...
Similar Threads - light AVL58 transmitter Forum Date
AVL58 vs Lightbridge for P2 FPV (First Person View) Jul 10, 2014
First flight and a couple of questions General Discussion Yesterday at 4:40 PM
Best Phantom Shots - Flight Techniques General Discussion Yesterday at 3:27 PM
Cockspur Island Lighthouse at dawn Phantom 4 Discussion Yesterday at 11:38 AM
Flight logs Standard/4k Discussion Yesterday at 11:28 AM