Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No Lift off!!!

Discussion in 'Phantom 2 Vision Help' started by Thomas Cole, Dec 11, 2015.

  1. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    Flew few weeks ago....everything normal. Went to fly today and all showed nominal but when I down sticked to lift off it would not. Motors seen to be running at different speeds. Am going to try computer calibration and reset defaults.

    Phantom Vision 2........thx any clues?
     
  2. JKDSensei

    Joined:
    Jun 24, 2015
    Messages:
    1,511
    Likes Received:
    658
    Location:
    USA
    Did you have to props off during that time?
     
  3. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    No I didn't, was sitting on desk with props on.
     
  4. JKDSensei

    Joined:
    Jun 24, 2015
    Messages:
    1,511
    Likes Received:
    658
    Location:
    USA
    Unusual that you would need to do a recalibration just from it sitting on a desk for a few weeks.
    But that's what I would do first.

    Just one other thing, I raise my left stick to lift off. When you say "down-sticked" can you explain that? Just sounds odd.

    Check your Geo-fencing settings also.
     
  5. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    God for a second I thought I was screwed up, no I meant up stick. I did a test with motors running. Upper left and upper right both front motors running high speed, rear motors much slower. Up centre no lift.
     
  6. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    Battery is new and showing perfect stats......props like new....good gps and good batteries in controller.
     
  7. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    Ok....it was a total brain fart.......figured out I for some reason I switched sticks in my head and assumed something wrong....not surprised got used to many minor glitches and still am gunshy! Thx for help JKD.....all good.
     
  8. JKDSensei

    Joined:
    Jun 24, 2015
    Messages:
    1,511
    Likes Received:
    658
    Location:
    USA
    Sometimes it's the "not-so-technical" solution :)
    Glad you got it figure out.

    To Infinity and Beyond !