Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No Gimbal Movement on P3 Pro

Discussion in 'Pro/Adv Discussion' started by BMDTV, Oct 7, 2015.

  1. BMDTV

    Joined:
    Jun 1, 2015
    Messages:
    4
    Likes Received:
    1
    I crashed my P3 Professional recently and the gimbal was damaged. The gimbal yaw arm broke, and the camera image became intermittent as well. We replaced the broken arm with a gimbal repair kit, and also installed a new ribbon cable. After this, we currently have no gimbal movement at all on power up. There is a green flashing light on the front of the gimbal. Any suggestions are much appreciated.
     
    richardtomcat likes this.
  2. richardtomcat

    Joined:
    Nov 19, 2015
    Messages:
    83
    Likes Received:
    9
    Location:
    Estes Park, Colorado
    Dealing with same. However, the "green" light you're talking about becomes red once my copter is finished with systems check. Installed new yaw arm and ribbon cable. No problems with reassemble. Followed awesome YouTube video. All connections good and straight. DJI cable from DJI. Replacement yaw fits like a glove. Power up and nothing .. no gimbal or camera. No motor/board damage, all covers good/not warped, no dings.
     
    #2 richardtomcat, Feb 29, 2016
    Last edited: Feb 29, 2016
  3. Arcticm39

    Joined:
    Feb 16, 2016
    Messages:
    55
    Likes Received:
    12
    Location:
    Maui
    Did you use OEM ribbon cable?
    All contacts fully inserted in slots?
    The yaw and roll arm motor shafts aligned correctly?
     
    richardtomcat likes this.
  4. Nic Nappier

    Joined:
    Jul 10, 2016
    Messages:
    2
    Likes Received:
    0
    Did you ever figure it out? I'm currently having same ussue