Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No flying for me over the holidays. (White Smoke)

Discussion in 'Pro/Adv Discussion' started by fin032, Dec 29, 2015.

  1. fin032

    Joined:
    Dec 5, 2014
    Messages:
    359
    Likes Received:
    44
    Location:
    Fife, Scotland
    Downloaded the latest firmware and put it on the card. Inserted it with the battery and turned the P3 on. Went to walk away to let it do its stuff. Noticed white smoke coming from the off side vent so grabbed the P3 and pulled the battery. Theres also a strong smell of burning plastic. After inspecting I seen that one of the cables leading to the camera had melted. No sure if there's any damage inside but glad I never just walked out the room. It's just had a new camera fitted no long back. ImageUploadedByPhantomPilots1451407317.922473.jpg
     
    #1 fin032, Dec 29, 2015
    Last edited: Dec 29, 2015
  2. fin032

    Joined:
    Dec 5, 2014
    Messages:
    359
    Likes Received:
    44
    Location:
    Fife, Scotland
    Any one any idea what could have cause this?
     
  3. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    Perhaps the insulation got cracked or rubbed off, could it be catching on something in your case or gimbal guard?
    Very close to USB socket if clumsily inserted (sorry but you asked!)
     
  4. fin032

    Joined:
    Dec 5, 2014
    Messages:
    359
    Likes Received:
    44
    Location:
    Fife, Scotland
    The insulation melted off as soon as I turned the P3 on. It took around 2 seconds to do that. Was trying to work out what could have caused it to melt.
     
  5. willbaroo

    Joined:
    Dec 28, 2015
    Messages:
    12
    Likes Received:
    4
    Location:
    United Kingdom
    You need to bring it up with who ever fitted your new camera surely?
     
  6. fin032

    Joined:
    Dec 5, 2014
    Messages:
    359
    Likes Received:
    44
    Location:
    Fife, Scotland
    Will do.
     
  7. kphantom

    Joined:
    Sep 12, 2015
    Messages:
    373
    Likes Received:
    80
    Inserting the memory card while turned on?
     
  8. ianwood

    ianwood Taco Wrangler
    Staff Member

    Joined:
    Jan 7, 2014
    Messages:
    4,910
    Likes Received:
    1,789
    Location:
    Lost Angeles
    Likely a short. Whoever put the new camera on did so incorrectly.
     
  9. fin032

    Joined:
    Dec 5, 2014
    Messages:
    359
    Likes Received:
    44
    Location:
    Fife, Scotland
    The card was inserted before the quad was turned on. I have been in contact with the shop and they are wiling to take the ways back to check it over.