Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No camera, no camera status light?

Discussion in 'Phantom 2 Vision + Help' started by Monkeyleg, May 31, 2015.

  1. Monkeyleg

    Joined:
    May 13, 2015
    Messages:
    305
    Likes Received:
    27
    I'm working on my older Phantom, and it has an issue. The camera doesn't work now. There's also no status light on the front of the gimbal main control box. No red light, not green light.

    Any ideas where to start looking?

    Thanks for any replies.
     
  2. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,731
    Likes Received:
    3,450
    First thing to check is the three cables that come down from the Phantom and go into the gimbal base.
    Make sure they are all pushed in properly - bent tweezers might be useful for this.
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    +1000. This happens on hard landings.

    If that fails then you may need to do a full firmware reset. let us know and i can point in the right direction to reset firmware for gimbal.
     
  4. Monkeyleg

    Joined:
    May 13, 2015
    Messages:
    305
    Likes Received:
    27
    I've had the two cables in front get a bit loose on me, to the point where the camera didn't work. When that happened, though, the red light above the camera "on" button was lit. In this case, there's no light on at all, not green or red. I have the connectors in their bases. I felt them click in.