Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No camera function or signal after DBS Mod installation

Discussion in 'Pro/Adv Discussion' started by Jeff, Oct 3, 2015.

  1. Jeff

    Joined:
    Jun 29, 2014
    Messages:
    17
    Likes Received:
    1
    Location:
    Ontario, Canada
    I recently installed the new range extender from DBS on my P3P. I followed all install instructions without issues. While I was at it, I also installed the new HDMI output board. Closed everything up, powered on the rc then the drone and nothing. No camera action on the drone at start up or camera response at the rc (live feed etc.) I also preformed a update on the rc, as it prompted me too.
    Any ideas???
     
  2. Jbundy63

    Joined:
    Jun 11, 2015
    Messages:
    623
    Likes Received:
    164
    I did my DBS Mod about a month ago but not the HDMI Mod. I had no problems. You didn't by any chance power up the controller without the antenna leads connected while after performing the mod? Just a thought
     
  3. 2raaas

    Joined:
    Jul 9, 2015
    Messages:
    88
    Likes Received:
    10
    Is the light on the controller red or green? (When both p3 and rc are on), powering up the rc without antenna leads connected will fry your rc.
     
    Jbundy63 likes this.
  4. 2raaas

    Joined:
    Jul 9, 2015
    Messages:
    88
    Likes Received:
    10
    You should get the 'camera dance' on the p3 when you switch it on no matter what.