Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Nightmare after firmware update

Discussion in 'Standard/4k Discussion' started by Fflorin Tataru, May 9, 2016.

  1. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    Hello All,

    I realize, at this point, it is too late for anybody to help me, but I wanted to share my experience so others can avoid something similar happening to them.
    I have been flying drones for the past two years so I had my share of close calls.
    I got my new P3S sometime in March and everything was perfect on the older firmware. When the new 1.4.6 came out, I had an issue upgrading, so I had to restart and try again. Everything went ok the second time (even if I thought there was a loss in flying distance in the same area I used to usually fly it).
    Once the new 1.5.7 came out, I wanted to update right away, hoping this will fix the distance issue.
    This upgrade went wrong right from the beginning. After about 2 min the camera started moving very rapidly up and down. I left it for about 5 min, but the camera got REALLY hot, so I stopped the upgrade and restarted the drone and controller. The drone started making that awful beeping sound, but the upgrade seemed to progress just about fine, so I let it finish.
    Once done, the camera was still very hot, so I let it cool down, and then I restarted everything and cheeked the camera picture and the gimbal movements, without starting the motors or test flying the drone.
    The picture was as usual and the gimbal movements seemed to be ok, so I kind of forgot the issue.
    For the following two weeks I had no time to fly it, so I kept in in the backpack. Last Saturday, I did a hike in the forests around Vancouver, so I decided to take the drone and take some video (I did it before, in the same spots, without any issue). The first mistake was that I didn’t do any test flight before heading out. As the camera and gimbal were ok I assumed the firmware did not mess any of the other functions.
    Once I reached the place I wanted to take video (a small water fall), I calibrated the compass, waited for the GPS to get position and started the motors (Go App shower safe to fly and I had about 9 satellites). Everything looked ok, so I took off. As soon as it was at about 6 ft, it started going all over the place. I tried to compensate but it was drifting like crazy. As soon as I left it hover, it was going back really fast. Trying to compensate from the controller overcompensated, so I ended up doing a hard landing, but everything was ok with the hardware.
    At this point, I was stupid enough to think that the currents from the water fall were at fault, even if I could not feel any – the air was completely still –the fall was about 50 m away.
    I packed everything and I headed back to a big clearing where I knew for sure it was no wind.
    Once there, I redid the calibration and all the other checks and took off again. It started drifting strongly, right away. I did not want to crash it so, I thought, if I fly it higher I will have more control (it was a huge clearing so I was not concerned about trees).
    I raised to about 20m and it started drifting REALLY bad to the forest. I tries to compensate but the drifting was way stronger than my commands. Once it got over the trees, I hit RTH and watched the screen. It just drifted back and forth for about 2 min then, suddenly, started descending without any reason, in the forest, about 60 m from my position. This is when I lost control and I went to look for it.
    It took about 5 min to find it on the forest floor, camera and half of the gimbal ripped from the body and the battery out of the compartment. I realized the drone was done, so I packed everything and went home.
    Once home I removed the gimbal mount and isolated the wires, so they did not touch each other.
    Amazingly I could still start the motors and fly the drone so I took it in the back yard for a test. As soon as I took off, it started doing the same crazy drifting back and forth and the control was useless. Every command either over or under compensated, so I ended up crashing from a low altitude (about 0.5m). Every new try ended the same, so I gave up.
    At this point, I made peace with the thought I have no P3S anymore but, not knowing why, is driving me nuts.
    Before the last firmware, everything was perfect. It could hover forever, even in really strong winds, and I did fly it in the same spot it crashed now.
    I know this is a really long post, but I hope somebody will come with an idea about where I went wrong and if it is anything I can do at this point (warranty coverage went to hell when I did not sent it in after the last messed up update).

    Thank you.
     
    #1 Fflorin Tataru, May 9, 2016
    Last edited: May 9, 2016
  2. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
  3. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
  4. AngryBird

    Joined:
    Feb 1, 2016
    Messages:
    192
    Likes Received:
    55
    Location:
    Lithuania
    I had drifting issue after update too. It happen above river, but I managed to get it back safely. What helped for me is relinking RC, recalibrating RC and recalibrating IMU.
     
  5. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    Hi, never re-calibrated the IMU after firmware update. Only before the first flight. I realize I should have done it when first noticed the drift. Well, too late now....I will try to replace the flex gimbal flat cable and see what happens. Thank you.
     
  6. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    If you load up your flights to HD, then share a link like I did. Some people will give your there thoughts, maybe even give you an answer.
     
  7. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    I will get the Flight Records from my IPhone later, tonight, and upload them. Thank you.
     
  8. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    Hi,
    Here's my flight data on HD. Not really helpfull to figure out what happened. Where you can see that, obviously, was something wrong, is in the animation saved on the IPhone, in the Go app. There you can see that the drone was going in opposite direction of my controls, and that was, also, drifting right from the beginning. It there any way to download that from the app? Thx.

    HealthyDrones.com - Innovative flight data analysis that matters
     
  9. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    OK, Hum, Looked at the HD file, maybe would want to see some older ones, super tired, will contact the Master4! Starts M and ends with 4.
     
  10. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,765
    Likes Received:
    3,470
    Looks like some bad luck there.
    Unfortunately Healthy Drones only gives a basic summary but doesn't display the dadta needed to see what was going on.
    If you go to http://www.phantomhelp.com/LogViewer/Upload/
    Follow the instructions to upload your flight record.
    Come back and post a link to the report it provides and perhaps someone will be able to work out what was going on.
     
  11. toegema

    Joined:
    Mar 10, 2016
    Messages:
    206
    Likes Received:
    43
    Dji says to recalibrate IMU after firmware update.
    I always do it.


    Sent from my iPhone using PhantomPilots mobile app
     
  12. OrlyP

    Joined:
    Feb 10, 2016
    Messages:
    210
    Likes Received:
    80
    Location:
    Metro Manila, Philippines
    I also think it's the IMU. It's very likely that its stored reference values were messed up during the non-typical firmware update.
     
  13. peterepeat69

    Joined:
    Mar 18, 2016
    Messages:
    549
    Likes Received:
    110
    Another update nightmare movie, I never update and this concludes my thoughts yet again, peace to you.


    Sent from my iPad using PhantomPilots mobile app
     
  14. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    Thanks,
    I must be missing something, when I have looked at the logs from PH I have seen less information the HD.
    Anyways as I was typing this, I just remembered a dream from last night, I was flying and it drifted between some branches I was trying to get away from them. I must have done it, don't remember the end. :D
     
  15. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    When you viewing your flight the Icon bottom right will let you forward the flight, I guess. I had an android touch screen quit and I hadn't saved all my flights to the cloud. I downloaded all my files to the PC with usb cable and copied the flights to another device that had DJI-Go Installed.
    So that would be a yes, must test.;)
     
  16. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    Hi again,
    I got an RMA from DJI, so i will ship the bird back to them, for diagnosis and repair. I will keep everyone posted. Meanwhile, i will post links to the flight animation and actual flight video (the low res one form the Phone, the one on the SD is just a blank screen)). Thank you everyone for your input.
     
  17. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    Is this going to USA, somebody was complaining it was going to cost like $75.00 to send from Canada.
     
  18. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    About 53 CAD. Not cheap but, if they honor warranty, is worth it.
     
  19. Fflorin Tataru

    Joined:
    May 9, 2016
    Messages:
    9
    Likes Received:
    0
    Location:
    Vancouver, BC, Canada
    As promised:

    link to Phantom Log:

    Phantom Log Viewer - PhantomHelp.com

    link to the flight animation from GO app:



    link to the actual flight video (the one form the IPhone, the one form SD card was corrupted)



    As you can see in the animation, the drone was drifting back even with the controller full forward. As soon as i hit RTH it returned without any issue (so it was not the wind), only to drift again at the end.
    Also the lack of wind can be seen in the video. The tree branches are almost still.

    Thank you all, again, for your help.
     
  20. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    Thanks eh, We can all learn from this stuff, the data from the log, I still don't get much from it. Maybe Master-4 will stop-bye.
    ;)