Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

newbie STORM FPV, iOSD = nothing

Discussion in 'FPV (First Person View)' started by edibob11, Jul 10, 2014.

  1. edibob11

    Joined:
    Jun 27, 2014
    Messages:
    47
    Likes Received:
    0
    Location:
    Austin, TX 78717
    I finally hooked up my STORM transmitter and iOSD, and now my H3-3D gimbal acts all erratic - weird. Plus there is no video being transmitted (received?) at all. Very frustrating. I have been careful to follow the setup diagram I got from helipal.com,

    Can anyone suggest troubleshooting techniques?

    Thanks
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    We'll need more details on how you have everything connected, pics would be great too
     
  3. edibob11

    Joined:
    Jun 27, 2014
    Messages:
    47
    Likes Received:
    0
    Location:
    Austin, TX 78717
    Well DUH ... After I turned the CAMERA ON, the video works just fine (how embarassing).

    BUT - the gyro still goes crazy, and the phantom 2 does not start now ... ???

    Another question - regarding the H3-3D gimbal - it came with a small circuit board - is that a "GCU", and should it NOT be used with a Phantom 2?
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    If it's a bare circuit board with a port on either end, it's just the anti-interference board DJI included with the H3-3D + P2 sets. I haven't seen it make any difference one way or the other.
     
  5. edibob11

    Joined:
    Jun 27, 2014
    Messages:
    47
    Likes Received:
    0
    Location:
    Austin, TX 78717
    This is a picture of the circuit board - not "bare" ... next to the STORM transmitter
     

    Attached Files:

  6. edibob11

    Joined:
    Jun 27, 2014
    Messages:
    47
    Likes Received:
    0
    Location:
    Austin, TX 78717
    Video says this is an "anti-interference board", so I guess it's required ...

    HOWEVER - the gimbal still acts erratic, and the Phantom 2 will not "start" when levers are moved as required. I have flown this guy several times, and never had an issue with it starting ... ?