Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. sphinx

    Joined:
    Jun 27, 2016
    Messages:
    2
    Likes Received:
    0
    I've spent about four hours working on this and want to reach out to the community before I ship it back to B&H. Here's the issue:

    I can launch the Assistant 2 app and get the little circle drawing instructing me to plug in the USB. But when I power on and plug in the Phantom 4, nothing happens... Assistant still waits for me to plug in the Phantom, even though it's plugged in. I know the cable is good because the computer operating system recognizes and mounts the SD card. The Phantom 4 begins to beep a single beep every few seconds. Solid green light over the gimbal.

    Additional info:
    I've tried on a Windows 8 laptop as well as a 2011 Macbook Pro running Yosemite. Made sure I installed the driver. On the PC, I made sure I ran as administrator. On the Mac, I changed the OS security setting to allow third party apps to run. Tried restarting both computers. Tried different USB cables. Tried removing the memory card. Tried a blank memory card. Tried it with the controller on and off.

    Possibly relevant:
    On the mac, when I launch Assistant, I get a pop up asking if it's ok for Assistant to connect to the internet (or something along those lines). I click yes.

    This is the first time I've tried Assistant. I did the previous firmware update when I first got the Phantom 4 by saving the file to the memory card and turning the Phantom on with the memory card in it. It appears this method is no longer available? Am I missing something obvious here?
     
  2. sphinx

    Joined:
    Jun 27, 2016
    Messages:
    2
    Likes Received:
    0
    Nevermind guys. I'm a moron.
     
  3. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,932
    Likes Received:
    1,149
    Location:
    Brookeville, MD, USA
    No - you're just a n00B. We were all n00Bs at one time. :grinning:

    Welcome to the site!
     
  4. r62ewa

    Joined:
    Mar 30, 2016
    Messages:
    556
    Likes Received:
    145
    Be good to post what you found so others can learn from your issue and solution, I'm sure others might have the same problem.
     
  5. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,891
    Likes Received:
    1,084
    Location:
    Yorba Linda, CA
    Don't feel bad, it's not unusual to take 2hrs to figure out DJI software when something new arrives. And sometimes it simply doesn't work. It's SOP. Welcome to the world of DJI ;-)
     
  6. Big Eoin

    Joined:
    Apr 13, 2016
    Messages:
    25
    Likes Received:
    1
    I have had the same problem and just gave up and uninstalled Assistant. If you got yours to work I would like to know how.


    Sent from my iPhone using PhantomPilots mobile app
     
  7. Sim597

    Joined:
    Mar 5, 2016
    Messages:
    1,040
    Likes Received:
    266
    Yeah, read what others have posted and make your problem and fix to the forum for others, that's the thing about these places, they're for others' problems and fixes, not just your/our own


    Sent from my iPhone using PhantomPilots mobile app