Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Newbie issues

Discussion in 'Phantom FC40 Discussion' started by yaz731200, May 11, 2014.

  1. yaz731200

    Joined:
    May 11, 2014
    Messages:
    2
    Likes Received:
    0
    Hello just picked up an FC40 from maplin, i followed all the set up instructions from the dji video but when i turn transmitter on then plug in battery all the lights flash ect i gave it a few mins but nothing, i have a single green flash, then if i put any imput on the controller then green light flashes more. but not movement at all from props, once in a while whilst still trying to use the controller the red light would flash but no particular pattern i can decifer?

    Had a hunt around and maybe i need to get the assistant software and do somthing with that?
    BUT i only have a macbook running OS X 10.5.8 so i cant even put the application on it. any ways around or anyone know if i have just made a simple mistake upon set up?

    Many thanks
    Yaz!
     
  2. HeliTV

    Joined:
    Apr 26, 2014
    Messages:
    45
    Likes Received:
    0
    You need to move both sticks to a corner and hold them there to start the props.

    Worth double checking the manual though as your fc40 may be different to my phantom 2...
     
  3. yaz731200

    Joined:
    May 11, 2014
    Messages:
    2
    Likes Received:
    0
    Ohh god I jumped the gun.
    If I had read the next page on the set up PDF that's all I needed to do.
    Pillock!!