Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

New Phantom vision V3.08 or V3.10?

Discussion in 'Phantom 2 Vision Discussion' started by Sean_joburg, Feb 5, 2015.

  1. Sean_joburg

    Joined:
    Feb 5, 2015
    Messages:
    18
    Likes Received:
    10
    Hi guys new to this awesome hobby and would like to find out what version do I upgraded my phantom to as I've read some weird stuff that's happened to some guys that upgraded to V3.10. I Picked up my phantom yesterday and would like to know what route to take before my first flight. Thanks
     
  2. p fandango

    Joined:
    Aug 2, 2014
    Messages:
    600
    Likes Received:
    27
    Location:
    Coventry, UK
    3.10 has been dropped
     
  3. gcbuss

    Joined:
    Oct 2, 2014
    Messages:
    39
    Likes Received:
    0
    Is anybody else still having problems with the app crashing when the gimbal is moved? I have v3.08 and app 1.0.46.
     
  4. brushlesheaven

    Joined:
    Jan 29, 2014
    Messages:
    250
    Likes Received:
    6
    DJI is working with apple store to reload the bug free 1.0.46
    We have to wait...




     
  5. gcbuss

    Joined:
    Oct 2, 2014
    Messages:
    39
    Likes Received:
    0
    The new iOS app 1.0.48 is in the App Store.
     
  6. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,622
    Likes Received:
    5,693
    Location:
    Amory Mississippi
    And a big Welcome to the forum Sean_joburg :D
     
  7. Werewolf

    Joined:
    Apr 3, 2014
    Messages:
    82
    Likes Received:
    1
    I'm having issues with 1.0.48 and 3.08. I have live feed, but cannot control the camera. And I also don't get any info regarding the gps status. Phantom seems to be not connecting to satellites. It stays at zero and is grayed out.
     
  8. Spiritskeeper

    Joined:
    Feb 4, 2015
    Messages:
    83
    Likes Received:
    1
    Plug your bird up to the assistant software for 3.10, don't worry it won't download 3.10. See if you are up to date on the other firmware on your bird.

    If it should say 3.10 is available and ready to upgrade don't do that one. 3.10 has done major issues that led to the pulling of it by DJI.

    BTW 1.0.48 iPhone App is rock solid on my stock setup and iphone 6 plus
     
  9. brushlesheaven

    Joined:
    Jan 29, 2014
    Messages:
    250
    Likes Received:
    6
    Yap, tested mine and it works fine....




    BTW 1.0.48 iPhone App is rock solid on my stock setup and iphone 6 plus[/quote]