Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional New Phantom, update fails

Discussion in 'Phantom 3 Help' started by anttler, Jul 21, 2016.

  1. anttler

    Joined:
    Jul 21, 2016
    Messages:
    2
    Likes Received:
    0
    I have a new Phantom 3 Pro. I did all the updating and everything worked was able to get a ready to fly in the house. Went outside and the gimbal started beeping while the Go DJI apps said "No connection" I was unable to pair the controller with the drone. Looking at fixes it wanted me to update the firmare again. I tried and the firmware update fails. Matter of fact, it looks as though deleting the firmware update .bin would have been the thing to do but I didn't as I missed (not even sure I have yet found) where that might be a good thing to do. Anwyay the firmware fails everytime now and it will not pair to the controller. All the drone does is beep from the gimbal. Does anyone know fix? Support gave me an RMA for it, but I'd rather fix it now than send it in for a month,

    Thanks in advance for your help
     
  2. ElGuapo

    Joined:
    Jul 18, 2016
    Messages:
    674
    Likes Received:
    201
    Location:
    Burbank, CA
    Make sure the remote controller is off..

    I had the same problem last night, P3P. Same symptoms that you are describing. My mistake was that the remote controller was on. I turned off the RC and the update worked out just fine.
     
Loading...
Similar Threads - Phantom update fails Forum Date
UPDATE IOS DJI GO APP FOR PHANTOM ADVANCED Control (Go, Litchi, etc..) Apr 27, 2017
Phantom 3 Advanced Firmware Update Pro/Adv Discussion Apr 24, 2017
Phantom 4 Firmware update April 2017 Phantom 4 Help Apr 15, 2017
P3 Firmware Not Update New Phantom to Latest Firmware? Firmware Mar 27, 2017
How Do I Physically Update Firmware on Phantom 4 Pro? Phantom 4 Help Mar 21, 2017