Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. mmarkoe

    Joined:
    Mar 24, 2016
    Messages:
    24
    Likes Received:
    1
  2. Terminus

    Joined:
    Jun 6, 2016
    Messages:
    12
    Likes Received:
    0
    I was just about to post about having to choose between obstacle sensing and propeller guards. I will be checking their product, Thanks!

    ETA I just ordered these but I had trouble with joining AliExpress I am not getting any of the transaction or confirmation mail. This seems to be the only place in the world you can buy them.
     
    #2 Terminus, Jun 26, 2016
    Last edited: Jun 26, 2016
  3. Wayne Routhier

    Joined:
    Apr 5, 2016
    Messages:
    10
    Likes Received:
    2
    I was able to get around the OA shut down by removing the black lines with paint thinker.

    The problem I ran into was during forward flight the OA system would see the guards and stop the drone causing very jerky flight.
     
  4. Anthony Zdubek

    Joined:
    May 17, 2016
    Messages:
    5
    Likes Received:
    1
    These work fine on mine.[​IMG]


    Sent from my iPhone using PhantomPilots mobile app
     
  5. maseman88

    Joined:
    Mar 23, 2016
    Messages:
    321
    Likes Received:
    139
    so 15 dollars each? 60 bucks for them? dang
     
  6. Terminus

    Joined:
    Jun 6, 2016
    Messages:
    12
    Likes Received:
    0
    No $15 for a full set.
     
  7. m0j0

    Joined:
    Dec 26, 2015
    Messages:
    1,533
    Likes Received:
    530
    Tempting fate I think but hey... P4 can be had for 1100 on ebay now.. Roll the dice.
     
  8. Anthony Zdubek

    Joined:
    May 17, 2016
    Messages:
    5
    Likes Received:
    1
     
  9. Erised

    Joined:
    Apr 2, 2016
    Messages:
    804
    Likes Received:
    333
    I thinking about doing that, removing the black stripes, so this worked for you Wayne?
     
  10. Terminus

    Joined:
    Jun 6, 2016
    Messages:
    12
    Likes Received:
    0
    I got mine today. They are causing intermittent obstacle alerts causing flight to be interrupted. It seems to happen during forward motion. I have tried to refit them a few times and I had one propeller that was clipping the protector despite adjusting it a few times. I am not sure what is going on there. Here are a few images that you can see them.
     

    Attached Files:

    #10 Terminus, Jul 13, 2016
    Last edited: Jul 13, 2016
  11. Wayne Routhier

    Joined:
    Apr 5, 2016
    Messages:
    10
    Likes Received:
    2
    That was the issue I was having with the front guards. I now only use the rear guards. I like the added visibility the rear guards provide, mine are painted green. I have not noticed any change in flight characteristic.
     
  12. AshMoussa

    Joined:
    Jul 3, 2016
    Messages:
    8
    Likes Received:
    4
    I just received my Tozo propeller guards today (from Amazon from a seller in China), threw them on my Phantom 4 (front and back) and ran a simple Litchi mission up and down my street. The first time I ran the mission it flew flawlessly then the 2nd & 3rd time I ran the mission it went up vertically and proceeded slowly forward and then stopped after a bit mid air and started rising higher and higher but very slowly. I could not get it to move forward or backwards. I even tried lowering it but it would not and it continued to rise higher. So I switched to S and was able to regain control landing it safely. I wonder if the guards had anything to do with it. I'll try the mission tomorrow w/o the guards to see if that was the problem. On another note after these incidences/flights and @ 35% I got a "critically low voltage warning" on a brand new, first time/flight, freshly charged battery. I wonder if the two events are related? I did turnoff the drone and controller, then back on, flew it hovering off the ground for a bit, landed it, and the error disappeared.
     
  13. Terminus

    Joined:
    Jun 6, 2016
    Messages:
    12
    Likes Received:
    0
    That is concerning. If you repeat the test with the obstacle avoidance system disabled does it still happen? Have you also updated Phantom firmware recently? Thanks for the update.