Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

New P3A...need to update firmware (also litchi?)

Discussion in 'Pro/Adv Discussion' started by AP4me, Feb 21, 2016.

  1. AP4me

    Joined:
    Jan 30, 2016
    Messages:
    62
    Likes Received:
    3
    So I have been REALLY enjoying my new P3A and it has been flying without issue. Of course, it's letting me know I have a few upgrades that I "need" to do. Then I have also read some on here don't, or don't go with the most current.

    Currently I have

    2.6.0 for the App
    1.5.7 for the RC
    1.4.10+ for the P3A

    Should I be upgrading? From reading the horror stories of attempted upgrades, it freaks me out! I don't want to brick something that's working now?

    Also, if anyone is using the litchi app, will I need to upgrade to use that safely when the time comes (possibly tomorrow)?

    Thanks for any and all help!
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,780
    Likes Received:
    5,525
    Location:
    US
    1.4 is an okay firmware to use. If you want to upgrade, skip 1.5 and go right to 1.6. It's easy to update the firmware if you do it correctly. I suggest you follow these instructions exactly.
     
  3. shockwave199

    Joined:
    Dec 19, 2014
    Messages:
    1,066
    Likes Received:
    404
    Litchi support mentions they test only with the latest firmware so in that respect it's probably best to be current for best results with litchi.
     
  4. AP4me

    Joined:
    Jan 30, 2016
    Messages:
    62
    Likes Received:
    3
    Awesome! Thanks! How long should I put aside for my updates?
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,780
    Likes Received:
    5,525
    Location:
    US
    Plan for about an hour to go through my instructions above.