Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

New P2 maiden flight - crash...

Discussion in 'Phantom 2 Discussion' started by darren, Jul 9, 2014.

  1. darren

    Joined:
    Jul 5, 2014
    Messages:
    8
    Likes Received:
    0
    Location:
    Wiltshire, UK
    Hi,

    Received my P2 + Zenmuse H3-3D today.

    All set up okay, and did a quick test flight. I couldn't get it to just hover when I took my hands off the controls. It kept drifting in an arc, and at one point just lost power. The battery was 100% at the start, and about 35% when I finally stopped. I'll need to fly it again to see if the drift is always in the same direction.

    I managed a couple of crashes. No obvious damage other than scuffs (no chips or dents) to the props.

    I updated the firmware before the first flight, and completed the compass calibration.

    Has anyone seen anything like this before? Any idea what I should do?

    Thanks

    Darren.
     
  2. TodayTrader

    Joined:
    Apr 20, 2014
    Messages:
    65
    Likes Received:
    0
    Do you have video?
     
  3. Detroit

    Joined:
    May 6, 2013
    Messages:
    118
    Likes Received:
    28
    Location:
    Ann Arbor MI
    Are you waiting for it to get a solid GPS lock? Did you you do the advanced IMU calibration? Are you sure you calibrated the compass correctly?
     
  4. darren

    Joined:
    Jul 5, 2014
    Messages:
    8
    Likes Received:
    0
    Location:
    Wiltshire, UK
    Hi,

    Quick update: I've had full GPS lock on all flights, and calibrated the compass. I went out the other day for another flight and put a new set of props on. I didn't get any problems with that flight. I can only assume that either the props were faulty in some way, or (more likely...) the first crash I had damaged them in some way.

    Regards

    Darren.
     
  5. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    It would fly surprisingly normally even with serious chunks out of the props.
    The drifting sounds like it was in ATTI mode or did not have enough satellites, that could happen during the flight,even if you had enough at take-off.
    It wouldn't explain the power loss though