Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware New Firmware and Galaxy Pad S2 Problem

Discussion in 'Firmware' started by MtyPilot, Nov 24, 2015.

  1. MtyPilot

    Joined:
    Nov 24, 2015
    Messages:
    17
    Likes Received:
    6
    I installed the latest remote control firmware (version 1.4.30) on my professional P3 and after that my Samsung Galaxy Tab S2 stopped connecting. When I try a Samsung Galaxy S5 cell phone everything works fine. I have already activated the USB debuging (developers) mode on the Tab S2 and when it's connected to my computer I can see all files stored in it, that means that it's connecting properly to my computer but not to the P3 remote control. Before the update it worked fine with the P3.

    Any help or comments will be greatly appreciated.
     
    #1 MtyPilot, Nov 24, 2015
    Last edited: Nov 24, 2015
  2. Albert D

    Joined:
    Aug 22, 2015
    Messages:
    155
    Likes Received:
    27
    Location:
    Winter Springs, Florida
    Did you update your controller (through DJI Go)? Also, did you verify the .txt file that upgrade was successful? Did you check if Litchi or something else was set as default for USB? I have Tab S2 and updated everything yesterday, with no problems and great test flights. I never activated USB debugging and don't have any issues. My Tab S2 is still pretty much right out of the box configuration (from AT&T) with only a few extra apps added.
     
  3. MtyPilot

    Joined:
    Nov 24, 2015
    Messages:
    17
    Likes Received:
    6
    I did update the remote controller with the DJI app on my Galaxy S5 cell phone last monday and it was installed correctly but that update was the reason why the tablet stoped connecting. I think there is a newer update that maybe was the one that you installed. I will try it. I don't understand what you mean by litchi.
    Thank you.
     
  4. Albert D

    Joined:
    Aug 22, 2015
    Messages:
    155
    Likes Received:
    27
    Location:
    Winter Springs, Florida
    In settings-applications-default applications, check that no other program is set as the default for the USB. If so, clear that (litchi was just an example of an app that could be set there). All the newest firmware updates came out just a couple days ago. I believe DJI Go updated about the same time.
     
    #4 Albert D, Nov 29, 2015
    Last edited: Nov 29, 2015
  5. MtyPilot

    Joined:
    Nov 24, 2015
    Messages:
    17
    Likes Received:
    6
    In settings-applications-default applications there are no option for USB default applications, what is shown are applications like Chrome, google maps, dropbox, etc. I am, on a trip right now but will try to install the new firmware tomorrow to see if that helps. Thank's.
     
  6. MtyPilot

    Joined:
    Nov 24, 2015
    Messages:
    17
    Likes Received:
    6
    Today (30-NoV-2015) I updated to the latest firmware of both the radio control (with the DJI Go app and a Galaxy S5 cell phone) as well as the Phantom 3 proffesional by means of the camera memory card. The Tab S2 still refuses to connect to the radio. My S5 cell phone connects with no problem. Is anyone having the same problem?