Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

New downgrade firmware you doing it?

Discussion in 'Firmware' started by 1st_time_flyer, Feb 5, 2015.

  1. 1st_time_flyer

    Joined:
    Dec 11, 2014
    Messages:
    123
    Likes Received:
    7
    Anyone else get the email this morning from DJI saying that we should downgrade the quad back down to 3.08 because there has been major issues with 3.10. Also noticed they said people with ios devices should downgrade even if they had issues with the app crashing when moving the camera because they have submitted a new update to the app store.......anyone downgrading to 3.08 again? I have no issues with 3.10 and it fixed my app crash....not sure what I should do...
     
  2. gcbuss

    Joined:
    Oct 2, 2014
    Messages:
    39
    Likes Received:
    0
    I have 3.08 and the app 1.0.46. It is horrible. The app keeps crashing when I move gimbal in app. I would like for dji to provide an updated app that works with the 3.08 firmware.
     
  3. 1st_time_flyer

    Joined:
    Dec 11, 2014
    Messages:
    123
    Likes Received:
    7
    they said they submitted a new one to the app store to fix that issue....but I "thought" that's why they released 3.10....guess they had more issues than before with 3.10.....but I haven't seen any of them....may just stay with 3.10 unless someone else can give me a reason to change back that i'm not seeing.
     
  4. Eltrochaphantom

    Joined:
    Dec 29, 2014
    Messages:
    286
    Likes Received:
    0
    Location:
    Uruguay
    And what about the gimbal, cause some people where having problems when they downgraded to 3.8
     
  5. 1st_time_flyer

    Joined:
    Dec 11, 2014
    Messages:
    123
    Likes Received:
    7
    I'm not sure I haven't seen where anyone posted about the issues with the gimbal and 3.08....isn't DJI great lol?
     
  6. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    I haven't had any issues with 3.08 - I am going to stay on it to be safe until others say 3.10 is ok (but I thought I read they pulled that update down?)
     
  7. 1st_time_flyer

    Joined:
    Dec 11, 2014
    Messages:
    123
    Likes Received:
    7
    they are pulling it down....for anyone that has already loaded 3.10 they suggest you downgrade....I have had no issues with 3.10 on my bird and don't plan on downgrading.
     
  8. Mori55

    Joined:
    Feb 13, 2014
    Messages:
    1,993
    Likes Received:
    6
    Location:
    NJ-USA
    Maybe they'll fix it so you can see the rear indicator lights in the app while in naza mode, not just phantom mode.
     
  9. Electric Warrior

    Joined:
    Jun 22, 2014
    Messages:
    123
    Likes Received:
    28
    Location:
    East Sussex, United Kingdom
    I downgraded from 3.10 to 3.08 as in 3.10 I was getting a battery error warning. 3.08 is working great!
     
  10. Mbuenfil

    Joined:
    Feb 6, 2015
    Messages:
    3
    Likes Received:
    0
    I've been having issues with Firmware 3.10.

    The morning after updating it, flew the P2V+ until depleting one batt. I took it down and then replaced the batt for a charged one and it was just after finishing the start sequence that the "MC: Invaild Battery" legend came up in the VISION App. Replaced it for another charged one and same story. GPS starts, the camera works, gimbal levels, gets 13 satellites but there's no engine start.

    Checked out YouTube and forums and some said it had to be something with the small spring connectors at the battery bay. That wasn't my case.

    When I connected the phantom to my Mac, the Assistant Software alert said that my battery wasn't valid. Downgraded the Firmware from 3.10 to 3.8 as adviced by DJI and upgraded the Assistant Software by downloading the 3.8 version straight from DJI's website. Also read that someone had issues with the iOS VISION App 1.0.46 and waited for DJI to release the latest version - as they said through a pop up in the App - which they did just a few hours ago.

    Already updated the iOS VISION App App to 1.0.48 and I am still getting the "MC: Invalid Battery" message.

    Any ideas?
     
  11. J.James

    Joined:
    Apr 21, 2014
    Messages:
    1,882
    Likes Received:
    162
    Location:
    Upstate NY
    Why would any one of been foolish enough to want to downgrade up to 3.10 in the first place to even worry about going back to 3.8 ???? esp when v3.10 was not even offering any added functionality and only taking away stuff and dji's attempt to play big step brother/nanny