Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Need to find a way to change pitch lever range

Discussion in 'General Discussion' started by pmacafee, Jan 24, 2015.

  1. pmacafee

    Joined:
    Dec 29, 2014
    Messages:
    27
    Likes Received:
    0
    So my Walkera gimbal works correctly and the pitch lever is calibrated correctly. I have narrowed the range in the Nazam setup so that max up is straight ahead for the camera and max down is strait down. The problem is that now the lever has big "dead zone" at each end of it's travel and since the lever is on the bottom of the controller I can't see where it is positioned, so when it comes time to smoothly pan up and down I move the lever a little and nothing happens and I do that several times until the lever comes into the "working zone" in the middle of the range of motion. By then it is too late for the proper timing of the video. Is there a way to calibrate the pitch so that the full range of the lever equals only the useful range of straight ahead to straight down? The work around might be to use the spare little adhesive rubber feet and block the lever's range of motion on each side so I can only move it in the range where it effects change.
     
  2. TheRob

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0
    Location:
    South Jersey
    I'm having the same issue with my Walkera G-2D (plastic) mounted to my Phantom 1.1.1. Did anyone ever find a fix for this?
     
  3. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    When you run the Assistant software, do you see a Gimbal tab under the Advanced section?
     
  4. PTCX

    Joined:
    Aug 25, 2013
    Messages:
    407
    Likes Received:
    61
    Location:
    Australia
  5. TheRob

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0
    Location:
    South Jersey
    Yes, I do see the Gimbal settings in the Advanced tab. I've already adjusted them to get my desired min/max range of motion (straight forward facing, and straight downward facing, screenshot attached), but nothing on this tab seems to affect the dead zones on both ends of the range of motion of the pitch lever on the controller. The defaults for Pitch Max and Min were 1000 and -1000 respectively. This resulted in the gimbal pitching too far in both directions. 415 and -95 seems to be the closest to perfectly horizontal and perfectly vertical. The Center value doesn't seem to do anything.

    If anyone has solved this, a solution would be greatly appreciated.
     

    Attached Files:

  6. Fyod

    Joined:
    May 21, 2014
    Messages:
    684
    Likes Received:
    61
    Location:
    Central EU
    Donwload RC assistant.
    Plug the controller into your PC.
    Click calibrate.
    Do the stick motions it tells you, then concentrate on the X1.
    Turn the knob to both max/min a couple times.
    Click finish.

    It should now have no dead spots.


    [​IMG]
     
  7. TheRob

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0
    Location:
    South Jersey
    I've done a full controller calibration already, just checked it again and the pitch lever correctly registers 1000 thru -1000 when I move it. However, this got me thinking: with the adjusted gimbal settings of 415 thru -95 to limit the movement of the gimbal, maybe that means the pitch lever will only function in that range of movement, thus the dead zones on both ends?
     
  8. Fyod

    Joined:
    May 21, 2014
    Messages:
    684
    Likes Received:
    61
    Location:
    Central EU
    When you say pitch lever, do you mean the tilt potentiometer on the back of the Phantom controller?
    Your best bet is to get rid of that horrid thing anyways. Get a good 20K (iirc) pot and a nice knob and you'll be far better off and able to make nice pan shots.