Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Need Help with a WiFi Problem

Discussion in 'Phantom 2 Vision + Discussion' started by phalcon51, Feb 5, 2015.

  1. phalcon51

    Joined:
    Jan 26, 2015
    Messages:
    66
    Likes Received:
    1
    I've got a new P2V+ v3 running 3.08 (upgraded to 3.10 then downgraded again) and I'm having some problems with the WiFi connection. When I connect it with my iPhone 5S it's a good solid connection. However, when I try connecting it to either my Galaxy S4 or my Galaxy Tab 3 using either the DJI Vision app or the Ultimate Flight app the WiFi connection turns itself off after about 35-40 seconds. When I connect it says that there is a very strong signal. While it's connected the green light on the WiFi extender flickers constantly and sometimes goes off completely for a couple of seconds, unlike on the iPhone where it's mostly solidly green. Sometimes after turning off the Phantom WiFi is available immediately for connection again but on a few occasions it would be at the bottom of the list labeled "Not in Range". After scanning for new connections 5-6 times it would then show as available again. Additionally, I didn't have this problem before upgrading to 3.10. I don't know if there's any connection or not.

    Is this a phone/tablet problem or is there something wrong with my WiFi extender?

    Is there any thing I can do within the phone or tablet settings to create a stronger connection?

    Also, on a separate note, I've noticed that my camera responds to the yaw control, with or without the motors running, by turning maybe 5 degrees either way. Is this normal?

    Thanks for any help.

    Gary
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    In android 4.2 kit kat (Samsung Galaxy Note 4), there is a "Smart Network Switch". Disable this. This will switch to another network if the signal is stronger or if it has a valid internet connection. When it find the Phantom_XXXXXX SSID and there is no internet access, it will switch to another.

    And the yaw movement on your camera is normal. It's designed to counter sharp yaw movements. Some prefer this off as they experience exaggerated yaws when they try to stop.
     
  3. phalcon51

    Joined:
    Jan 26, 2015
    Messages:
    66
    Likes Received:
    1
    Thanks for the reply Mako79.

    Can you tell me where I can find the "Smart Network Switch" setting on the Galaxy S4 or the Galaxy Tab 3? I just went through the Settings on the Tab 3 (I don't have the S4 handy at the moment) and I couldn't find anything like that.
     
  4. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Mine is under settings > wifi settings. It should be at the top of where you nominate a wifi network.
     

    Attached Files:

  5. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    928
    Likes Received:
    74
    Location:
    Manchester UK
    On my Samsung go into wifi list and press the bottom left button and choose settings, I think it's called auto network switch , you will get a message your internet connection is unstable but that's ok